View topic - slogger log file corruption

slogger log file corruption

Discussion about the general applications that run on QNX6

slogger log file corruption

Postby bugmenot » Sat Jun 07, 2008 10:02 am

Hello,

I'm using slogger ( slogger -l /tmp/log) to log messages received by can driver. The problem is a garbage that periodically appeares in log. No other application writes to the log (I've checked this. When drivers doesn't work there is nothing in log ).
What's wrong?

E.g.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x4a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x5a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3a0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x6a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x3b0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3b0 and length 8 byte(s) received.
Feb 17 17:48:16 2 683621 515 980579442 1679831072 979465313 671100960 1052782 10002 319928614 1852534357 544110447
........
this garbage appears periodically ( period: 4-10 seconds )
........
1936942445 543516513 1752459639 543451424 1647605808 185100960 771100960 1056254 10002 319928614 1852534357
Mar 23 19:48:33 7 222573 1847 with id 0x3a0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x5b0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x3a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x4a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x6b0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x5a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3a0 and length 8 byte(s) received.

Oasis Palm Cancun
Sexo Por Telefono
Last edited by bugmenot on Fri Feb 14, 2014 6:46 pm, edited 1 time in total.
bugmenot
New Member
 
Posts: 4
Joined: Thu Oct 06, 2005 9:39 pm

RE: slogger log file corruption

Postby bugmenot » Sat Jun 07, 2008 12:05 pm

Next test.
This program writes test messages.

//main
while(1)
{
delay(100);
slogf( 1,1,"%s","test");
}

slogger is running ("slogger -l /tmp/log").

I inspect log file by the command:
"sloginfo /tmp/log".
Garbage appeares in 3 minutes after the start.

There is no problems when i use /dev/shmem/log as log file.

I have QNX 6.3.2 running on x86 proceesor board ( CF is used as hrad disk )
bugmenot
New Member
 
Posts: 4
Joined: Thu Oct 06, 2005 9:39 pm

Re: slogger log file corruption

Postby madokapeng » Wed Jan 09, 2019 7:11 pm

any solutions to solve this?

I am experiencing the same issue.
madokapeng
New Member
 
Posts: 3
Joined: Wed Jan 09, 2019 4:37 pm

Re: slogger log file corruption

Postby nico04 » Thu Jan 10, 2019 7:47 am

Do you really need a log file ?
Running "slogger" is enough (reading with "sloginfo").
nico04
Senior Member
 
Posts: 125
Joined: Wed Sep 29, 2010 9:59 am
Location: France


Return to QNX6 - Applications

Who is online

Users browsing this forum: No registered users and 0 guests