View topic - python 2.2.2 on QNX 6.2.1

python 2.2.2 on QNX 6.2.1

Discussion about the general applications that run on QNX6

python 2.2.2 on QNX 6.2.1

Postby shli » Wed May 14, 2003 10:28 pm

Hi, I am new in this group.
I recently installed python 2.2.2 (from 3rd party CD)
on my QNX 6.2.1 box (dual PIII 1GHz CPUs with 1GB memory).
I tried to run python there, but the startup time takes about 10 seconds
(from typing "python" on the shell till python prompt showup).
Is this normal? Why does it take so long? Or do I miss something?
shli
New Member
 
Posts: 5
Joined: Wed May 14, 2003 10:16 pm

Postby noc » Fri May 16, 2003 3:38 am

Have you tried the python build for qnx6 from ?
http://sourceforge.net/projects/pyqnx
noc
Senior Member
 
Posts: 1634
Joined: Sat Jul 06, 2002 4:34 am

Postby shli » Fri May 16, 2003 8:57 am

I just tried building the python 2.2.1 for QNX6 from SourceForge.
It looks much normal now. But I can only build the core,
not those extension modules. Anyway to fixthis?
BTW, I also tried the python 2.2.1 from the older version
3rd party CD. It's also very slow to startup.
shli
New Member
 
Posts: 5
Joined: Wed May 14, 2003 10:16 pm

Postby cdm » Fri May 16, 2003 10:20 pm

It has to do with fs-pkg. If you run a "hog -n -%1" while you start python you will see that fs-pkg is consuming an insane amount of CPU time while python starts. This will hopefully be fixed in a future release. You can either get the 2.2.1 from openqnx or the 2.2.2 sources from the 3rd Party CD and rebuild and install without a package. The openqnx version doesn't include the shared libpython.so however.
cdm
QNX Master
 
Posts: 789
Joined: Fri Jul 05, 2002 9:38 am

Postby shli » Fri May 16, 2003 10:53 pm

Thanks for the reply.
I couldn't find python 2.2.2 source from the 3rd party CD.
Is that installed under /pkgs/repository?
Also I have problem building extension modules in the 2.2.1
from openqnx. Is that becuase libpython.so is not included?
shli
New Member
 
Posts: 5
Joined: Wed May 14, 2003 10:16 pm

Postby shli » Fri May 16, 2003 11:30 pm

FYI,

if I run python with "-S", the startup time is only about
one-third or half of with "-S". So I guess the long delay
has something to do with importing those default modules.

Earlier when I ran the 2.2.1 python core that I built locally,
it was very quick. I guess part of the reason is I failed to
build those extension modules at that time. So it doesn't
spend time loading them when startup.
shli
New Member
 
Posts: 5
Joined: Wed May 14, 2003 10:16 pm


Return to QNX6 - Applications

Who is online

Users browsing this forum: No registered users and 1 guest