View topic - Why patches for QNX 6.6 for Media n App ?

Page 1 of 1

Why patches for QNX 6.6 for Media n App ?

PostPosted: Fri Jan 08, 2016 5:58 am
by pramodama
Hi All,

We are trying to use QNX 6.6 and when we build our workspace, it gave the following error.

Line 124: Host file 'C:/qnx660/target/qnx6/armle-v7/usr/sbin/mm-renderer' not available.

As per the searches, to fix the error, we need few patches.

Applypatch Patch (Patch ID 4024)
Header Files Patch (Patch ID 3851)
Audio Patch (Patch ID 4006)
Graphics Patch (Patch ID 3875)
Graphics Patch (Patch ID 4036)

But when we try to install the patches, it shows newer version of patch is already installed. It means, we are trying to instrall 6.5 version ka patches on top of 6.6 ?

Please let us know.

Re: Why patches for QNX 6.6 for Media n App ?

PostPosted: Fri Jan 08, 2016 7:29 am
by nico04
Have have installed Apps and Media dev package ?

Re: Why patches for QNX 6.6 for Media n App ?

PostPosted: Fri Jan 08, 2016 7:39 am
by pramodama
When we try to install App and Media framework, it gave error and related search directed us to install the patches.

Re: Why patches for QNX 6.6 for Media n App ?

PostPosted: Fri Jan 08, 2016 8:09 am
by nico04
6.5.0 and 6.6.0 are installed in different directories (on Windows, I believe this is also true on linux) so both frameworks are usable simultaneously.
Apps and Media framework must be installed only on 6.6.0 framework.

Re: Why patches for QNX 6.6 for Media n App ?

PostPosted: Wed Jan 13, 2016 2:11 pm
by denkelly
>>>But when we try to install the patches, it shows newer version of patch is already installed. It means, we are trying to instrall 6.5 version ka patches on top of 6.6 ?
This can happen when certain files are updated by bsp installations. When the patch install prompts to overwrite newer file, you will need to say "yes" - it's likely re-writing the same file you have (or one with same functionality) but with the patch date/time. After the required patches install, you will be able to install AnM 1.1.