View topic - Samba 3 for 6.3.0

Samba 3 for 6.3.0

Discussion about the general applications that run on QNX6

Samba 3 for 6.3.0

Postby MarkD » Thu Apr 07, 2011 7:47 pm

I've searched and couldn't find a compiled binary of Samba rev 3 for QNX 6.3.0 (no service packs) or QNX sourced Samba greater than rev 2.

I downloaded the Samba source from the Samba website and tried to compile it but it gives me errors saying that autoconf > 2.53 and autoheader aren't installed. I do have autoconf 2.57 installed. Not sure how to fix that.

A link to binaries, source code, or some hints on compiling the source code would be appreciated.

Mark
MarkD
Active Member
 
Posts: 14
Joined: Tue Jun 17, 2003 3:09 pm

RE: Samba 3 for 6.3.0

Postby maschoen » Sat Apr 09, 2011 4:35 am

If you are not stuck on 6.3.0 I would recommend upgrading to at least 6.3.2 and maybe 6.5. Then you might want to look at pkgsrc.
Some up front work with lots of benifits later.
maschoen
QNX Master
 
Posts: 2720
Joined: Wed Jun 25, 2003 5:18 pm

RE: Samba 3 for 6.3.0

Postby MarkD » Mon Apr 11, 2011 4:52 pm

We are stuck on 6.3.0, my understanding is that binaries from the newer versions of QNX can't be used on older versions. We have hundreds of systems in the field that are constantly being updated.

Just had an idea. We could use a trick. We could setup a system with a newer version of QNX using the newer samba and use symbolic links on the new system to map to the older QNX systems. Best of both (hopefully).
MarkD
Active Member
 
Posts: 14
Joined: Tue Jun 17, 2003 3:09 pm

Re: RE: Samba 3 for 6.3.0

Postby maschoen » Mon Apr 11, 2011 7:57 pm

MarkD wrote:We are stuck on 6.3.0, my understanding is that binaries from the newer versions of QNX can't be used on older versions. We have hundreds of systems in the field that are constantly being updated.

Just had an idea. We could use a trick. We could setup a system with a newer version of QNX using the newer samba and use symbolic links on the new system to map to the older QNX systems. Best of both (hopefully).


If everything is in the same location, yes you could do that. When you start the QNX network, you need to load the "compatible" version so that 6.3.0 and 6.5.0 can talk. (I think this is the case, or maybe it was 6.2 that had this problem).

I am quite certain however that you can get Samba and Auto(whatever) to run on 6.3.0, but it may not be worth your time.
maschoen
QNX Master
 
Posts: 2720
Joined: Wed Jun 25, 2003 5:18 pm

Re: RE: Samba 3 for 6.3.0

Postby MarkD » Thu Apr 14, 2011 3:08 pm

maschoen wrote:If everything is in the same location, yes you could do that. When you start the QNX network, you need to load the "compatible" version so that 6.3.0 and 6.5.0 can talk. (I think this is the case, or maybe it was 6.2 that had this problem).

I am quite certain however that you can get Samba and Auto(whatever) to run on 6.3.0, but it may not be worth your time.


6.2 has the incompatible network type, 6.3 networking works fine with 6.5.

I setup a 6.50 system, setup pkgsrc, installed Samba and rc.subr, created the shares and symbolic links, configured Samba and... it works. It is a bit slow, but for editing text files it is OK. Our network connections don't drop out like they did with Samba 2.0.7.

Interesting that the Samba package from pkgsrc (rev 3.0.37) has a QNX specific bug in it so it won't compile without making a change. Later versions of Samba have that bug fixed.
MarkD
Active Member
 
Posts: 14
Joined: Tue Jun 17, 2003 3:09 pm


Return to QNX6 - Applications

Who is online

Users browsing this forum: No registered users and 8 guests