View topic - Network problem (localhost as ip address)

Network problem (localhost as ip address)

Discussion about the QNX6 OS.

Network problem (localhost as ip address)

Postby Ifflag » Fri Apr 13, 2018 7:00 pm

Hello, I have just installed QNX Neutrino 6.5.0 and I already get an network error. It seems like that I have no ip address, I have already reinstalled the OS but the problem is still there. And with the results of ifconfig and netstat -r I don't know where I have to start to resolve the problem.
I'm using QNX Neutrino 6.5.0 on my Desktop to connect it with my Laptop. On my Laptop I have installed the QNX Momentics IDE and I want to connect with my Desktop in order to work under a real time environment.
Attachments
IMG_2359 Kopie.jpg
I placed the results of netstat -r and ifconfig in one image
(1.54 MiB) Not downloaded yet
Ifflag
New Member
 
Posts: 5
Joined: Thu Apr 12, 2018 10:07 pm
Location: Belgium

Re: Network problem (localhost as ip address)

Postby maschoen » Sat Apr 14, 2018 5:24 am

Looking at your screen shots, I see you have only one visible adapter, lo0, which is a local adapter at 127.0.0.1. There does not seem to be a nic driver. Since you used the QNX installation disk, and it did not find any network hardware, here is what you should do.

1) Run the "pci" command and see if it finds any network hardware.

2) Assuming you found some hardware, use get the VID/DID (Vendor ID/Device ID). Check the QNX hardware database to see if it is listed.

If not, you need to get some supported network hardware in your machine.

If it is listed, you can try mounting the driver directly using the mount command.

What you are looking for when you run ifconfig is another network adapter, eg. en0. I've also seen rt0 and wm0 for different drivers. If a device is found, you can call it en0.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby Ifflag » Sun Apr 15, 2018 8:45 am

Thank you for your answer !
I entered the "pci | less" command and for the network adapter I got VID: 8086h (intel), DID:15a1 (Ethernet Connection (2) I218-V). I have looked after the QNX Database to check if the device is listed but I can't find the Database. Would it be possible if I download the Driver directly and install it in QNX Neutrino ?
Attachments
IMG_2363.jpg
"pci | less"
(725.93 KiB) Not downloaded yet
Ifflag
New Member
 
Posts: 5
Joined: Thu Apr 12, 2018 10:07 pm
Location: Belgium

Re: Network problem (localhost as ip address)

Postby maschoen » Sun Apr 15, 2018 6:38 pm

Well the first thing is to find out which driver you need. You could try them all one by one.

I have to say I'm beside myself on this. I just spent 5 minutes searching via google "QNX hardware Database" and also at their site. For the last 10 years there was a resource that allowed you to connect a VID/DID with a driver if it existed. I don't know if it is gone, or buried. This is the type of shit I've come to expect from QNX these days. Or rather they don't seem to give a shit about their customers. I'm going as high to the top as I can to find out what this is about. It may take a few days but I will get back to you on this.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby maschoen » Mon Apr 16, 2018 4:55 am

Ok, digging further I found the database at http://www.qnx.com/developers/hardware_support/

You can look yourself but the VID:DID you mentioned doesn't seem to be there. Which means it's unsupported. I'm guessing this is a NIC on the motherboard. There's a wide variety of cards that are supported, which you can check in the database.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby Tim » Wed Apr 18, 2018 9:27 pm

I just googled for that device id (15A1). Even though it claims to be Intel this link of their official hardware says it's not theirs but a 3rd party clone.

https://www.intel.com/content/www/us/en ... ducts.html

But if you google this 'intel 15a1 vendor id' I get tons of hits that says it's an 82544EI. That *is* supported on that hardware list for 6.5

Intel 82541EI Gigabit 0x8086: 0x1013, 0x1018, 0x1019 devnp-i82544.so, devn-i82544.so PPC, X86 Gigabit Ethernet Controller (Copper)

So you could take a chance and manually attempt to start the 82544EI driver and specify the 15a1 device id with it and see if that works.

Tim
Tim
Senior Member
 
Posts: 1419
Joined: Wed Mar 10, 2004 12:28 am

Re: Network problem (localhost as ip address)

Postby maschoen » Wed Apr 18, 2018 10:51 pm

Excellent idea with a catch. The driver probably has a list of supported VID:DID numbers. If the number is not on the list, even if the driver would work, it won't start.

I once had this problem with a USB to serial device. Until QNX got around to giving us the source to update the VID:DID table I was able to do the following.

1) Make a copy of the driver
2) Search the driver for the VID:DID table
3) Use spatch to overwrite an entry in the table with the one I wanted to work
4) Start the modified driver

You could try this, or maybe ask QNX for the driver source.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby Ifflag » Thu Apr 19, 2018 8:44 pm

@Tim
I will give it a try as soon as I am at home.
When I want to load the driver manually is this the right command to type in ?

io-pkt-v4-hc -t tcpip &
mount -T io-pkt "driver.so"

@maschoen
I have send an e-mail to the QNX support I will let you know what they will answer
Ifflag
New Member
 
Posts: 5
Joined: Thu Apr 12, 2018 10:07 pm
Location: Belgium

Re: Network problem (localhost as ip address)

Postby maschoen » Thu Apr 19, 2018 9:17 pm

No quotes around the driver name needed, although that shouldn't matter. The shell should remove them. Otherwise it looks ok.

Once you have it running properly it's possible to include the driver name in the start of io-pkt if you want. I don't know of any advantage or disadvantage.

The zapping the driver is a bit of a crap shoot as it presumes the driver will work with the new chip. Still it can't hurt to try. If it does work, definitely let QNX know to update their VID:DID table in the driver. I hope they will still pay attention to this kind of feedback, though I have my doubts.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby Ifflag » Tue Apr 24, 2018 2:43 pm

I have tried to start the driver manually but it didn't work,

io-pkt-v4-hc -t tcpip &
mount -T io-pkt devnp-i82544.so
when I tried this command I got an message error

io-pkt-v4-hc -t tcpip &
mount -T io-pkt devn-i82544.so
here I got NO message error but there was still just one visible adapter, localhost. I restarted the system but it didn't work either.

I sent an e-mail to services@qnx.com 5 days ago (already the third one) but they don't respond... is that supposed to be a customer-support ?
Ifflag
New Member
 
Posts: 5
Joined: Thu Apr 12, 2018 10:07 pm
Location: Belgium

Re: Network problem (localhost as ip address)

Postby Tim » Tue Apr 24, 2018 4:30 pm

Ifflag wrote:io-pkt-v4-hc -t tcpip &
mount -T io-pkt devn-i82544.so
here I got NO message error but there was still just one visible adapter, localhost. I restarted the system but it didn't work either.


Since the VID/DID isn't the normal ones you are going to have to manually provide them to devn-i82544.so

See here for how to specify VID/DID
http://www.qnx.com/developers/docs/6.5. ... 3_12_6_118

Tim
Tim
Senior Member
 
Posts: 1419
Joined: Wed Mar 10, 2004 12:28 am

Re: Network problem (localhost as ip address)

Postby Ifflag » Sat Apr 28, 2018 2:14 pm

I tried the following command:
-> io-pkt-v4 -d /lib/dll/devn-i82544.so, did=0x15a1, vid=0x8086 -v
"Unable to load devn-i82544,.so: Library cannot be found"
and this one:
-> io-pkt-v4 -t tcpip &
mount -T io-pkt-v4 /lib/dll/devn-i82544.so, did = 0x15a1, vid=0x8086
"mount: Can't mount did=0x15a1, (type io-pkt-v4)"
"mount: Possible reason: Invalid argument"

Maybe I have downloaded and installed the wrong version of QNX ?
Ifflag
New Member
 
Posts: 5
Joined: Thu Apr 12, 2018 10:07 pm
Location: Belgium

Re: Network problem (localhost as ip address)

Postby maschoen » Sat Apr 28, 2018 6:09 pm

It doesn't look like the wrong verison of QNX. It looks like the driver doesn't support your hardware.
maschoen
QNX Master
 
Posts: 2681
Joined: Wed Jun 25, 2003 5:18 pm

Re: Network problem (localhost as ip address)

Postby Tim » Mon Apr 30, 2018 1:59 pm

Ifflag wrote:-> io-pkt-v4 -t tcpip &
mount -T io-pkt-v4 /lib/dll/devn-i82544.so, did = 0x15a1, vid=0x8086
"mount: Can't mount did=0x15a1, (type io-pkt-v4)"
"mount: Possible reason: Invalid argument"


I don't think the comma after your driver (devn-i82544.so) is right.

See the bottom of this link for sample command of passing options directly to the driver:
http://www.qnx.com/developers/docs/6.4. ... o-pkt.html

Tim

P.S. I just noticed you are doing it via the mount command
http://www.qnx.com/developers/docs/6.5. ... mount.html

The examples section in that link says:
If you want to pass options to the driver, use the -o option before the name of the shared object:

mount -T io-pkt -o mac=12345678 devn-ne2000.so


Try (no space after comma)
mount -T io-pkt-v4 -o did = 0x15a1,vid=0x8086 /lib/dll/devn-i82544.so

Tim
Tim
Senior Member
 
Posts: 1419
Joined: Wed Mar 10, 2004 12:28 am

Re: Network problem (localhost as ip address)

Postby nico04 » Mon Apr 30, 2018 2:54 pm

Try (no space after comma)
mount -T io-pkt-v4 -o did = 0x15a1,vid=0x8086 /lib/dll/devn-i82544.so


I believe all spaces must be removed in the -o section :
mount -T io-pkt-v4 -o did=0x15a1,vid=0x8086 /lib/dll/devn-i82544.so
nico04
Senior Member
 
Posts: 102
Joined: Wed Sep 29, 2010 9:59 am
Location: France

Next

Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 6 guests