View topic - Clock unplanned offset

Clock unplanned offset

For the old QNX2 and QNX4 RTOS

Clock unplanned offset

Postby Shmendrik » Wed May 16, 2007 12:51 pm

Hi everybody,
I have this odd problem, once in a while system time change and goes exactly 10 hours ahead, it happens to all computers clusters (not connected to each other) and to all nodes connected in a cluster.
To fix the problem I need to use the “dateâ€
Shmendrik
New Member
 
Posts: 4
Joined: Wed May 16, 2007 6:20 am

RE: Clock unplanned offset

Postby micro » Wed May 16, 2007 3:53 pm

1st i think date does not really affect bios-time but an offset for the OS.
2nd is there NTP or similar time-daemons running, may chaining the wrong time to the next node in cluster?

Try setting fixed Time wihtin BIOS directly or use a Master NTPd, synchronising to official NTPd and let all other nodes
just ntp on your master NTPd.
micro
Senior Member
 
Posts: 458
Joined: Thu Jul 22, 2004 8:41 pm

RE: Clock unplanned offset

Postby mario » Thu May 17, 2007 1:01 am

What does your time zone look like?
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am

Thanks, but this does not solve problem

Postby Shmendrik » Thu May 17, 2007 5:21 am

I don't have NTP the cluster is isolated meaning, not connected to any large network, Micro is right of course, "date" does not effect bios time, just system time, there is the "rtc" command for this.
The problem about using one of the nodes as Master NTP is that I don't understand the problem so it could happen also to the master.
The time zone is set somewhere between +2 to -2 (it is deferent in some clusters from others).
Shmendrik
New Member
 
Posts: 4
Joined: Wed May 16, 2007 6:20 am


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 1 guest

cron