View topic - Unable to boot QNX 6.5.0 on Beaglebone black board.

Unable to boot QNX 6.5.0 on Beaglebone black board.

For discussion of realtime and/or embedded programming.

Unable to boot QNX 6.5.0 on Beaglebone black board.

Postby m gate » Thu May 29, 2014 6:56 am

Hi There,

I have downloaded QNX 6.5.0 starter kit BSP (bsp-nto650-ti-am335x-starter-kit-trunk-201307050950) imported in IDE, and built image from the source (haven't made any change in build script or code), image gets build successfully.

But when I copy newly built image on SD card and try to boot on beaglebone black board it fails with below error...

U-Boot# fatload mmc 0 81000000 ifs-ti-am335x-sk.bin

reading ifs-ti-am335x-sk.bin
14548544 bytes read in 1657 ms (8.4 MiB/s)
U-Boot# go 81000000

## Starting application at 0x81000000 ...
DDR DPLL in Lock mode:
DDR clock 400 Mhz [400/1]
Disp DPLL in Lock mode:
Disp clock 200 Mhz [200/1]
MPU DPLL in Lock mode:
MPU clock 550 Mhz [550/1]
PER DPLL in Lock mode:
PER clock 192 Mhz [960/5]
CORE DPLL in Lock mode:
M4 CORE clock 100 Mhz [1000/10]
M5 CORE clock 125 Mhz [1000/8]
M6 CORE clock 250 Mhz [1000/4]
CPU0: L1 Icache: 512x64
CPU0: L1 Dcache: 512x64 WB
CPU0: L2 Dcache: 4096x64 WB
CPU0: VFP-d32 FPSID=410330c3
CPU0: NEON MVFR0=11110222 MVFR1=00011111
CPU0: 413fc082: Cortex A8 rev 2 720MHz
Loading IFS...done
Jumping to QNX

System page at phys:80011000 user:fc404000 kern:fc404000
Starting next program at vfe046604
cpu_startnext: cpu0 -> fe046604
VFPv3: fpsid=410330c3
coproc_attach(10): replacing fe07601c with fe0758bc
coproc_attach(11): replacing fe07601c with fe0758bc
Welcome to QNX Neutrino trunk on the Texas Instruments AM335x Starter Kit (ARMv7 Cortex-A8 core) - Board

Shutdown[0,0] S/C/F=11/1/11 C/D=fe01c68c/fe099ff4 state(c0)= now lock
QNX Version 6.5.0 Release 2010/07/09-14:26:46EDT
[0]PID-TID=1-6? P/T FL=00019001/05020000 "proc/boot/procnto-instr"
[0]ASPACE PID=2 PF=00008012
armle context[effe8f4c]:
0000: 8ffb2000 8ffb2000 8ffb2c01 00000181 effccbf8 01000000 00000000 fc004000
0020: fc004000 effdf47c 01072fff 00000008 00000000 effe8f90 fe046878 fe040e0c
0040: 60000013
06 30 98 e7 1c 20 94 e5 11 00 12 e3 00 70 94 15 18 20 9d 15 07 70 82 11 0c 00
0000: effe8fbc e1de0000 00000000 efffb348 effca00c 003fffff 00000a2e e1ec1d70
0020: 8ffb2000 fffff000 00000000 00000007 00000040 effccbf8 fe099ff0 01000000
0040: 00000100 efff0090 00000073 0000008e effca6e8 fe044744 effccbf8 fe044ad0
0060: efffb348 fe069bac efffb348 fe071e30 effe9018 00000000 00000000 00000000
U-Boot SPL 2013.04-dirty (Jul 10 2013 - 14:02:53)

I followed this to understand what's the problem, and it seems that there is segmentation violation.

I don't have much experience in kernel debugging, so
Can anyone please help me to understand what's going wrong here? and how to solve this problem?

Please Note: Using prebuilt image file which comes with BSP package, I am able to boot.

Please help! I am fighting with this issue for last 3-4 days...
m gate
New Member
Posts: 5
Joined: Wed May 28, 2014 11:50 am

Re: Unable to boot QNX 6.5.0 on Beaglebone black board.

Postby denkelly » Fri May 30, 2014 1:17 am

Why are you trying to boot the "starter-kit" bsp on BBB when there is a specific bsp for BBB?
Senior Member
Posts: 163
Joined: Sat Aug 02, 2008 3:27 pm

Re: Unable to boot QNX 6.5.0 on Beaglebone black board.

Postby m gate » Fri May 30, 2014 6:30 am

Thanks for your reply.

I tried using pre-built image which comes with specific BSP for BBB but for some reason it didn't boot. When I tried with starter kit pre-built image, it worked, so I decided to go with starter kit BSP.

But when I am building image from starter kit BSP (simply by importing BSP in IDE and building without any change) it is not working, that's why I wanted to know whether I am missing some steps to build image.
I thought, if I am not making any change in code or config then it should work (similar to pre-built image).
m gate
New Member
Posts: 5
Joined: Wed May 28, 2014 11:50 am

Return to Realtime and Embedded

Who is online

Users browsing this forum: No registered users and 2 guests