Failing on "unreleased" packages

bridged with qdn.public.porting
Post Reply
William Morris

Failing on "unreleased" packages

Post by William Morris » Fri Apr 11, 2003 1:45 pm

I create a number of packages which I have been
installing on test systems with no problem.
However, on a new installation of 6.2.1 I am getting
the message:

"The package is unreleased and may not be installed"

from cl-installer. The package installs fine on my
development PC, so I imagine there is something wrong
with the target machine. Can anyone help please?

Thanks for any answers
William Morris

======================

Full output from cl-installer:

# cl-installer -i dsp-1.0-waukes.qpr

QNX Software Installer 1.00

Extracted QRM identifier
Opening "/pkgs/repository" repository and looking for packages...
Opening "/pkgs/base" repository and looking for
packages... Extracted QRM identifier
Opening "dsp-1.0-waukes.qpr" repository and looking for
packages... The package is unreleased and may not be
installed (dsp-1.0-waukes)

There are no packages to install.
Session closed

#

Jerry Chappell

Re: Failing on "unreleased" packages

Post by Jerry Chappell » Fri Apr 11, 2003 1:54 pm

Check the clock on your target machine. The installers ensure that the
ReleaseDate of the package has been reached before that package can be
installed (note that this rule is not enforced in 6.2.1 and later versions).

Jerry Chappell

"William Morris" <william@bangel.demon.co.uk> wrote in message
news:3E96C700.F986D322@bangel.demon.co.uk...
I create a number of packages which I have been
installing on test systems with no problem.
However, on a new installation of 6.2.1 I am getting
the message:

"The package is unreleased and may not be installed"

from cl-installer. The package installs fine on my
development PC, so I imagine there is something wrong
with the target machine. Can anyone help please?

Thanks for any answers
William Morris

======================

Full output from cl-installer:

# cl-installer -i dsp-1.0-waukes.qpr

QNX Software Installer 1.00

Extracted QRM identifier
Opening "/pkgs/repository" repository and looking for packages...
Opening "/pkgs/base" repository and looking for
packages... Extracted QRM identifier
Opening "dsp-1.0-waukes.qpr" repository and looking for
packages... The package is unreleased and may not be
installed (dsp-1.0-waukes)

There are no packages to install.
Session closed

#

William Morris

Re: Failing on "unreleased" packages

Post by William Morris » Fri Apr 11, 2003 2:17 pm

Jerry Chappell wrote:
Check the clock on your target machine. The installers ensure that the
ReleaseDate of the package has been reached before that package can be
installed
Thanks. The date was set to Match 14th
(note that this rule is not enforced in 6.2.1 and later versions).
Really? I am using 6.2.1
# uname -a
QNX target 6.2.1 2003/01/18-02:12:22est x86pc x86

Thanks very much for your help (and for such a quick reply).
William

Post Reply

Return to “qdn.public.porting”