Problem with Fujitsu Coral PA & Lite5200B

bridged with qnx.bsp
Post Reply
gerardo

Problem with Fujitsu Coral PA & Lite5200B

Post by gerardo » Wed Mar 07, 2007 3:58 pm

Hello,

I'm trying to make that a PCI graphic card with a Fujitsu Coral PA
chip (Fujitsu MB86296-EB01) works plugged on a Freescale Lite5200B
v.1.0 with, obviously, QNX. I'm using, of course, the Lite5200B BSP
downloaded from qnx.com to build the OS.

The problem is that, when I launch the PCI driver, pci-mgt5200, I
obtain the following message on the log register:

# sloginfo
Time Sev Major Minor Args
Jan 01 00:10:35 3 17 0 Range check failed (MEM) - Dev 201e -
Vend 10cf - Class 38000 - Addr 0 - Size 4000000

I obtain this error message with the Coral plugged on both PCI slots,
and I think that the Coral is correctly plugged: I have it connected
with its VGA and RCA connectors oriented to the side where the Lite
has the CAN, Ethernet, Serial and USB ports.

More details: when I switch on the Lite with the Coral plugged on it,
the 150, 151 and 152 leds are tuned on (only these leds).

I don't know what is causing the problem, and I don't find any
documentation about the PCI driver. I think, however, that is a
hardware problem, or perhaps something related with the U-Boot and
not due to the driver, but I don't know neither where the problem is
nor how to solve it.

Can somebody help me?

Thanks in advance.

Gerardo.

gerardo

RE: Problem with Fujitsu Coral PA & Lite5200B

Post by gerardo » Sun Apr 15, 2007 8:30 am

Hi again,

I have discovered that the problem was in the PCI port inicialization.
If I call the pci U-Boot command before download and execute the OS
image, the reported error dissapears (it seems that the pci command
does some kind of inicialization in order to obtain the information
it shows about the PCI ports).

However, I still have a problem because the io-graphics can't load the
Coral driver. When I execute the following io-graphics line (with the
DL_DEBUG=1 to obtain the next output) on my startup script:

DL_DEBUG=1 io-graphics -C/usr/photon/config/crtc-settings -dcoral
vid=0x10cf,did=0x201e,xres=640,yres=480,bitpp=16,photon,mode_opts=/usr/photon/config/coral.lite5200B.6.conf
-pphoton

I obtain the following output:

## Starting application at 0x00020000 ...
Welcome to QNX Neutrino 6.3 on the Freescale Lite5200B
Starting serial driver...
Starting PCI driver
Starting on-board ethernet with large stack
Starting Remote Debug...
Starting USB driver...
Starting Photon...
waiting for Photon...
Starting keyboard & mouse drivers...
Launching graphics driver...
load_object: attempt load of libgri.so.2
load_elf32: loaded lib at addr fe375000(text) fe385070(data)
load_object: attempt load of libfont.so.1
load_elf32: loaded lib at addr fe387000(text) fe392720(data)
load_object: attempt load of libm.so.2
load_elf32: loaded lib at addr fe393000(text) fe3b1db0(data)
load_object: attempt load of libdisputil.so.2
load_elf32: loaded lib at addr fe3b6000(text) fe3bc580(data)
dlopen("phfont.so",3586)
load_object: attempt load of phfont.so
load_elf32: loaded lib at addr fe3be000(text) fe3dede0(data)
dlsym(48062078,_btext)=48045edc
Library loaded; type 'add-sym phfont.so 48045edc' in gdb to load
symbols
load_object: attempt load of libfontharnessutils.so.1
load_elf32: loaded lib at addr fe3e4000(text) fe3e9540(data)
dlsym(48062078,PHFONT_INTERNAL_API)=fe3df140
dlopen("/lib/dll/font/ttfFFcore.so",2)
load_object: attempt load of /lib/dll/font/ttfFFcore.so
load_elf32: loaded lib at addr fe3ea000(text) fe3f4920(data)
dlsym(480620d8,_btext)=48045edc
Library loaded; type 'add-sym ttfFFcore.so 48045edc' in gdb to load
symbols
load_object: attempt load of libblkcache.so.2
load_elf32: loaded lib at addr fe3f6000(text) fe3f99d0(data)
load_object: attempt load of libFF-T2K-cache.so.2
load_elf32: loaded lib at addr fe3fa000(text) fe3fc590(data)
load_object: attempt load of libFF-T2K.so.2
load_elf32: loaded lib at addr fe3fd000(text) fe43cce0(data)
dlsym(480620d8,_font_retrieve_engine)=fe3f3810
dlopen("/lib/dll/font/PHFcore.so",2)
load_object: attempt load of /lib/dll/font/PHFcore.so
load_elf32: loaded lib at addr fe442000(text) fe449f70(data)
dlsym(48062120,_btext)=48045edc
Library loaded; type 'add-sym PHFcore.so 48045edc' in gdb to load
symbols
load_object: attempt load of libfontutils.so.1
load_elf32: loaded lib at addr fe44b000(text) fe44cfa0(data)
dlsym(48062120,_font_retrieve_engine)=fe448e60
dlopen("/lib/dll/font/FCcore.so",2)
load_object: attempt load of /lib/dll/font/FCcore.so
load_elf32: loaded lib at addr fe44e000(text) fe458a60(data)
dlsym(48062138,_btext)=48045edc
Library loaded; type 'add-sym FCcore.so 48045edc' in gdb to load
symbols
load_object: attempt load of libFF-T2K-fm.so.1
load_elf32: loaded lib at addr fe45a000(text) fe45d720(data)
dlsym(48062138,_font_retrieve_engine)=fe457950
Fatal error - check sloginfo.
waiting for graphics driver...
Unable to access "/dev/phfont" (2)
Launching lvds...
Starting i2c driver...
Starting Window Manager...
#

And the sloginfo output is:

# sloginfo
Time Sev Major Minor Args
Jan 01 00:00:00 3 17 0 Range check failed (MEM) - Dev 201e -
Vend 10cf - Class 38000 - Addr 0 - Size 4000000
Jan 01 00:00:00 5 10 0 Motorola MPC5200
Jan 01 00:00:00 5 10 0 Vendor .............. 0x0
Jan 01 00:00:00 5 10 0 Device .............. 0x0
Jan 01 00:00:00 5 10 0 Revision ............ 0x0
Jan 01 00:00:00 5 10 0 Interrupt ........... 0x45
Jan 01 00:00:00 5 10 0 Interrupt ........... 0x8c
Jan 01 00:00:00 5 10 0 MAC address ......... 00049f 005b15
Jan 01 00:00:00 5 10 0 devn-mpc5200: MII transceiver found
at address 0.
Jan 01 00:00:00 5 14 0 tcpip starting
Jan 01 00:00:00 3 14 0 Using pseudo random generator. See
"random" option
Jan 01 00:00:00 1 8 0 phfont_init
Jan 01 00:00:00 1 8 0 phfontXX started OK
Jan 01 00:00:00 1 8 0 FatalError
Jan 01 00:00:00 1 8 0 font extension error - unable to find
rule io-font
Jan 01 00:00:00 1 8 0 Unable to launch Photon Font Server
main.
Jan 01 00:00:00 2 8 0 Unable to open font DLL
Jan 01 00:00:03 5 10 0 devn-mpc5200: link up (100 BaseT Full
Duplex)
#

It seeems that the io-graphics loads the libFF-T2K-fm.so.1 library
but, after that, it can't take the following step.

I didn't know what the following step was but, after have analyzed the
io-graphics output in my Total5200, I realized that the following step
is the graphics driver load i.e., in this case, the devg-coral.so load
into memory.

I have the devg-coral.so placed into the /lib/dll directory, and this
directory included on both the LD_LIBRARY_PATH and the _CS_LIBPATH
environment variables, but on the io-graphics output I can't not even
see the "dlopen(...)" message, so I think that it can't find
the driver, but I don't really know whats going on.

I will be very grateful if somebody could help me.

Thanks in advance.

Gerardo.

gerardo

RE: Problem with Fujitsu Coral PA & Lite5200B

Post by gerardo » Sun Apr 15, 2007 8:30 am

In the previous message, I have made a mistake: I hadn't called the
pci command before launch the OS image, so I obtained the "Range
check failed" message.

When I call the pci command the I obtain the same log withouth the
mentioned message.

Sorry.

Gerardo.

fklein23

RE: Problem with Fujitsu Coral PA & Lite5200B

Post by fklein23 » Mon Nov 05, 2007 9:57 pm

I wish I got as far as you did!

Here's what I got:

=> tftp 20000 $(bootfile);run nfsargs addip;bootm
Net: FEC ETHERNET
Using FEC ETHERNET device
TFTP from server 10.0.0.2; our IP address is 10.0.0.1
Filename 'bsp-freescale-mgt5200b.ifs'.
Load address: 0x20000
Loading: T
#################################################################

#################################################################
##################################
done
Bytes transferred = 838536 (ccb88 hex)
## Booting image at 00020000 ...
Bad Magic Number
=> gp 20000
Unknown command 'gp' - try 'help'
=> go 20000
## Starting application at 0x00020000 ...
Welcome to QNX Neutrino 6.3 on the Freescale Lite5200B/Media5200

Then it froze. Any suggestions how to actually do an install of the
Lite5200B BSP?

Thanks - Frank

Post Reply

Return to “qnx.bsp”