Missing Operating System

bridged with qnx.rtos
Post Reply
Vijayarajuk

Missing Operating System

Post by Vijayarajuk » Tue Aug 21, 2007 5:56 am

Hi Experts,
I am using QNX 4.24 RTOS to boot my target. I made a copy of the same
to a new IDE Flash Drive, When I try to boot with original IDE Flash
Drive
target is booting well, But when I tried to boot from the new IDE
Flash Drive I am getting 'Missing Opearting System' error message.

I have one basic question, because I am getting this error while
booting.
My question is:

1) Why does we get 'Missing operating System' error message at the
time of booting?
can anybody explains me the possible ways for getting this error and
resolutions for the same. Please I need Error must be fixed for me as
soon as possible. Thanks in advance.

I hope somebody from this group will help me in this regard.

~Vijji

Mario Charest

Re: Missing Operating System

Post by Mario Charest » Tue Aug 21, 2007 12:33 pm

"Vijayarajuk" <vijayaraju.k@gmail-dot-com.no-spam.invalid> wrote in message
news:fadupv$7sq$1@inn.qnx.com...
Hi Experts,
I am using QNX 4.24 RTOS to boot my target. I made a copy of the same
to a new IDE Flash Drive, When I try to boot with original IDE Flash
Drive
target is booting well, But when I tried to boot from the new IDE
Flash Drive I am getting 'Missing Opearting System' error message.

I have one basic question, because I am getting this error while
booting.
My question is:

1) Why does we get 'Missing operating System' error message at the
time of booting?
That is because the BIOS didn't find a boot loader. Either the way you
copied the disk or you got bitten by a bug in Fsys.atapi which assigned
different geometry to master and slave disks.
can anybody explains me the possible ways for getting this error and
resolutions for the same. Please I need Error must be fixed for me as
soon as possible. Thanks in advance.

I hope somebody from this group will help me in this regard.

~Vijji

Vijayarajuk

RE: Re: Missing Operating System

Post by Vijayarajuk » Wed Aug 22, 2007 5:56 am

Hi,
Thnaks for the reply.
Any advice to resolve this problem.

~Vijji

maschoen

RE: Re: Missing Operating System

Post by maschoen » Wed Aug 22, 2007 7:56 am

Mario is correct that this has to do with different geometries of the
disks, but
assigning geometry to disks is not strickly a BIOS thing. There are
unfortunately
more than one definition of what the geometry of a disk is. Here are
some of them.

1) The actual geometry. This is amost never important anymore, but
for older disks, this was.

2) For LBA disks, the disk comes with a pre-assigned geometry.
3) LBA disks can also have a geometry assigned to them
4) A BIOS can implement its own geometry, which is translated.

I've never run into a bios that used different geometry based on
whether it was the primary or slave drive, but I don't doubt it
exists.

Even more unfortunately, I've seen bios's implement this in all
different
ways.

If you are having trouble, rather than doing an image copy, you might
want to try doing a file by file copy. If you do this with QNX
4.25, you will probably have to copy the /.boot file by hand, and
transfer licenses using "license", after the other files
are copied.

Post Reply

Return to “qnx.rtos”