Problems with Sandpoint X3 and Altimus mpmc7410

bridged with qdn.public.qnxrtp.powerpc
Post Reply
Dave Edwards

Problems with Sandpoint X3 and Altimus mpmc7410

Post by Dave Edwards » Wed Apr 03, 2002 1:43 pm

Hi I have a Sandpoint X3 main board with an Altimus 7410 processor
installed.

When I build a QNX image for this board and download it the system hangs
with no output whatsoever. After modifying the startup-sandpoint main.c
file to remove the following:

reference to "CALLOUT_SLOT ( reboot, _sandpoint)",
Turning off Ibat and Dbat translation,
call to "ppc600_init_caches()"

The board will boot fine, and I appear to have a working system with
serial channels and PCI control.

There is a cryptic reference to the 7410 in the documentation that
suggests that the only way to boot this board is by burning the IPL/OS
image onto the boot flash, but I cannot find an explanation as to why?

I believe that this may be a problem with the configuration of the rom
monitor (DINK32 V12.3) but so far I'm stumped.

Any Suggestions?

Dave

John Wall

Re: Problems with Sandpoint X3 and Altimus mpmc7410

Post by John Wall » Wed Apr 03, 2002 2:54 pm

Dave Edwards <nobody@home.com> wrote:
: Hi I have a Sandpoint X3 main board with an Altimus 7410 processor
: installed.

: When I build a QNX image for this board and download it the system hangs
: with no output whatsoever. After modifying the startup-sandpoint main.c
: file to remove the following:

: reference to "CALLOUT_SLOT ( reboot, _sandpoint)",
: Turning off Ibat and Dbat translation,
: call to "ppc600_init_caches()"

: The board will boot fine, and I appear to have a working system with
: serial channels and PCI control.

: There is a cryptic reference to the 7410 in the documentation that
: suggests that the only way to boot this board is by burning the IPL/OS
: image onto the boot flash, but I cannot find an explanation as to why?

In what doc did you find this reference? In any case you should be
able to boot the 7410 without modifying startup. The later versions of
DINK32 (12.1 >) turn on the caches. This causes us problems; simply
typing "rm hid0" followed by zero will alleviate the problem. Make sure
you do this before downloading the image.

The OS will take care of re-enabling the caches.

: I believe that this may be a problem with the configuration of the rom
: monitor (DINK32 V12.3) but so far I'm stumped.

Yep, you're correct.

--
John

Dave Edwards

Re: Problems with Sandpoint X3 and Altimus mpmc7410

Post by Dave Edwards » Wed Apr 03, 2002 3:30 pm

Thanks, That fixed it!

The cryptic message is in /bsp_en/sandpoint/install (under help) and
it says :

You cannot use DINK32 to boot the 7410 or 7450 board, you'll
have to burn the image into the flash using an EPROM burner..


Cheers

Dave


John Wall wrote:
Dave Edwards <nobody@home.com> wrote:
: Hi I have a Sandpoint X3 main board with an Altimus 7410 processor
: installed.

: When I build a QNX image for this board and download it the system hangs
: with no output whatsoever. After modifying the startup-sandpoint main.c
: file to remove the following:

: reference to "CALLOUT_SLOT ( reboot, _sandpoint)",
: Turning off Ibat and Dbat translation,
: call to "ppc600_init_caches()"

: The board will boot fine, and I appear to have a working system with
: serial channels and PCI control.

: There is a cryptic reference to the 7410 in the documentation that
: suggests that the only way to boot this board is by burning the IPL/OS
: image onto the boot flash, but I cannot find an explanation as to why?

In what doc did you find this reference? In any case you should be
able to boot the 7410 without modifying startup. The later versions of
DINK32 (12.1 >) turn on the caches. This causes us problems; simply
typing "rm hid0" followed by zero will alleviate the problem. Make sure
you do this before downloading the image.

The OS will take care of re-enabling the caches.

: I believe that this may be a problem with the configuration of the rom
: monitor (DINK32 V12.3) but so far I'm stumped.

Yep, you're correct.

--
John

John Wall

Re: Problems with Sandpoint X3 and Altimus mpmc7410

Post by John Wall » Wed Apr 03, 2002 3:50 pm

Dave Edwards <nobody@home.com> wrote:
: Thanks, That fixed it!

: The cryptic message is in /bsp_en/sandpoint/install (under help) and
: it says :

: You cannot use DINK32 to boot the 7410 or 7450 board, you'll
: have to burn the image into the flash using an EPROM burner..
Thanks,

Ok, I'll check into it. The info from the previous post (rm hid0)
is part of the next release.

--
John


: John Wall wrote:

:> Dave Edwards <nobody@home.com> wrote:
:> : Hi I have a Sandpoint X3 main board with an Altimus 7410 processor
:> : installed.
:>
:> : When I build a QNX image for this board and download it the system hangs
:> : with no output whatsoever. After modifying the startup-sandpoint main.c
:> : file to remove the following:
:>
:> : reference to "CALLOUT_SLOT ( reboot, _sandpoint)",
:> : Turning off Ibat and Dbat translation,
:> : call to "ppc600_init_caches()"
:>
:> : The board will boot fine, and I appear to have a working system with
:> : serial channels and PCI control.
:>
:> : There is a cryptic reference to the 7410 in the documentation that
:> : suggests that the only way to boot this board is by burning the IPL/OS
:> : image onto the boot flash, but I cannot find an explanation as to why?
:>
:> In what doc did you find this reference? In any case you should be
:> able to boot the 7410 without modifying startup. The later versions of
:> DINK32 (12.1 >) turn on the caches. This causes us problems; simply
:> typing "rm hid0" followed by zero will alleviate the problem. Make sure
:> you do this before downloading the image.
:>
:> The OS will take care of re-enabling the caches.
:>
:> : I believe that this may be a problem with the configuration of the rom
:> : monitor (DINK32 V12.3) but so far I'm stumped.
:>
:> Yep, you're correct.
:>
:> --
:> John
:>
:>


--
John Wall
QSSL
Custom Engineering Group (R&D)

Post Reply

Return to “qdn.public.qnxrtp.powerpc”