X11 with Scitech and Compaq Evo

bridged with qdn.public.ddk.graphics
Post Reply
Patrick Pfister

X11 with Scitech and Compaq Evo

Post by Patrick Pfister » Tue Mar 25, 2003 10:26 am

got new PCs (Compaq Evo310 Microtower) for our application, running X11 with
Scitechdriver on QNX 4.25...
TNT2 graphiccard (the only one I could find that still runs!!!)... onboard
VGA deactivated!
Photon start as quick as usual - X11 or better Scitechdriver (gatest and
startx) take up to 1 min to give an image !!!
Shutting down X11 is a little quicker (but still 15 seconds) :-(!
does anybody have answers to such things???
thanks for any hints!!!!

attached the graphics.log:


391 Mhz Unknown Intel processor with MMX(R), SSE(R)

Displaying enumeration of PCI bus (7 devices, 1 display devices)
Display device 0 is PCI device 5

Bus Slot Fnc DeviceID SubSystem Rev Class IRQ Base10h Base14h Cmd
0 0 0 8086:2560 0000:0000 01 06:00 00 F8000008 00000000 0106
0 1 0 8086:2561 0000:0000 01 06:04 00 00000000 00000000 0107
0 30 0 8086:244E 0000:0000 81 06:04 00 00000000 00000000 0107
0 31 0 8086:24C0 0000:0000 01 06:01 00 00000000 00000000 010F
0 31 1 8086:24CB 0E11:00C5 01 01:01 0A 00002091 000020A1 0005
1 0 0 10DE:002D 0000:0000 15 03:00 0A FD000000 F6000008 0027 <- 0
5 4 0 10EC:8139 10BD:0320 10 02:00 05 00001001 FC500000 0007

DeviceID Stat Ifc Cch Lat Hdr BIST Int Base18h Base1Ch Base20h Base24h
8086:2560 2090 00 00 00 00 00 00 00000000 00000000 00000000 00000000
8086:2561 00A0 00 00 40 01 00 00 20010100 22A000F0 FE10FD00 F7F0F5E0
8086:244E 8080 00 00 00 01 00 00 40050500 22801010 FC70FC50 0000FFF0
8086:24C0 0280 00 00 00 80 00 00 00000000 00000000 00000000 00000000
8086:24CB 0280 8A 00 00 00 00 01 00002099 000020A5 00002081 00000000
10DE:002D 02B0 00 00 40 00 00 01 00000000 00000000 00000000 00000000
<- 0
10EC:8139 0280 00 00 42 00 00 01 00000000 00000000 00000000 00000000

DeviceID BAR10Len BAR14Len BAR18Len BAR1CLen BAR20Len BAR24Len ROMLen
8086:2560 04000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:2561 00000000 00000000 07000100 FD5F1000 000F0100 000F0100 00000000
8086:244E 00000000 00000000 07000100 FD7F1000 000F0100 000F0100 00000000
8086:24C0 00000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:24CB 00000000 00000000 00000000 00000000 00000000 00000000 00000000
10DE:002D 01000000 02000000 00000000 00000000 00000000 00000000 00000000 <-
0
10EC:8139 00000000 00000100 00000000 00000000 00000000 00000000 00000000

Displaying enumeration of 4 bridge devices

DeviceID P# S# B# IOB IOL MemBase MemLimit PreBase PreLimit Ctrl
8086:2560 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000
8086:2561 00 01 01 F000 0000 FD000000 FE1FFFFF F5E00000 F7FFFFFF 0008
8086:244E 00 05 05 1000 1FFF FC500000 FC7FFFFF FFF00000 00000000 0006
8086:24C0 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000

GA_enumerateDevices: Found 1 PCI/AGP display devices

Valid ISV license found - using licensed options
Loading driver for device 0: 1 0 0 10DE:002D 0000:0000
---------------------------------------------------------

Monitor record loaded from disk:
Manufacturer... COMPAQ
Model.......... COMPAQ S710
Max Resolution. 1280x1024
Max HScan...... 70 KHz
Max VScan...... 160 Hz
Features....... DPMS

Attempting to enable write combining, base = 0xF6000000, length = 0x02000000
.... Success!
Attempting to disable caching for MMIO, base = 0xFD000000, length =
0x01000000 ... Success!

Graphics device configuration:
Manufacturer......... NVIDIA
Chipset.............. RIVA-TNT2 M64
Memory............... 32768 Kb
DAC.................. NVIDIA Internal 24 bit DAC
Clock................ NVIDIA Internal Clock
Memory Clock......... 15 Mhz
Default Memory Clock. 0 Mhz
Maximum Memory Clock. 0 Mhz
Driver Revision...... Build 8
Driver Build......... Feb 15 2000
Certified Version..... Not Certified

Driver for device 0 loaded successfully!
---------------------------------------------------------

David Donohoe

Re: X11 with Scitech and Compaq Evo

Post by David Donohoe » Tue Mar 25, 2003 3:02 pm

Patrick Pfister <patrick.pfister@pup.ch> wrote:
got new PCs (Compaq Evo310 Microtower) for our application, running X11 with
Scitechdriver on QNX 4.25...
TNT2 graphiccard (the only one I could find that still runs!!!)... onboard
VGA deactivated!
Photon start as quick as usual - X11 or better Scitechdriver (gatest and
startx) take up to 1 min to give an image !!!
Shutting down X11 is a little quicker (but still 15 seconds) :-(!
does anybody have answers to such things???
thanks for any hints!!!!
Try setting VBIOS_METHOD environment variable to 2, e.g.

export VBIOS_METHOD=2
attached the graphics.log:
391 Mhz Unknown Intel processor with MMX(R), SSE(R)

Displaying enumeration of PCI bus (7 devices, 1 display devices)
Display device 0 is PCI device 5

Bus Slot Fnc DeviceID SubSystem Rev Class IRQ Base10h Base14h Cmd
0 0 0 8086:2560 0000:0000 01 06:00 00 F8000008 00000000 0106
0 1 0 8086:2561 0000:0000 01 06:04 00 00000000 00000000 0107
0 30 0 8086:244E 0000:0000 81 06:04 00 00000000 00000000 0107
0 31 0 8086:24C0 0000:0000 01 06:01 00 00000000 00000000 010F
0 31 1 8086:24CB 0E11:00C5 01 01:01 0A 00002091 000020A1 0005
1 0 0 10DE:002D 0000:0000 15 03:00 0A FD000000 F6000008 0027 <- 0
5 4 0 10EC:8139 10BD:0320 10 02:00 05 00001001 FC500000 0007

DeviceID Stat Ifc Cch Lat Hdr BIST Int Base18h Base1Ch Base20h Base24h
8086:2560 2090 00 00 00 00 00 00 00000000 00000000 00000000 00000000
8086:2561 00A0 00 00 40 01 00 00 20010100 22A000F0 FE10FD00 F7F0F5E0
8086:244E 8080 00 00 00 01 00 00 40050500 22801010 FC70FC50 0000FFF0
8086:24C0 0280 00 00 00 80 00 00 00000000 00000000 00000000 00000000
8086:24CB 0280 8A 00 00 00 00 01 00002099 000020A5 00002081 00000000
10DE:002D 02B0 00 00 40 00 00 01 00000000 00000000 00000000 00000000
- 0
10EC:8139 0280 00 00 42 00 00 01 00000000 00000000 00000000 00000000

DeviceID BAR10Len BAR14Len BAR18Len BAR1CLen BAR20Len BAR24Len ROMLen
8086:2560 04000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:2561 00000000 00000000 07000100 FD5F1000 000F0100 000F0100 00000000
8086:244E 00000000 00000000 07000100 FD7F1000 000F0100 000F0100 00000000
8086:24C0 00000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:24CB 00000000 00000000 00000000 00000000 00000000 00000000 00000000
10DE:002D 01000000 02000000 00000000 00000000 00000000 00000000 00000000 <-
0
10EC:8139 00000000 00000100 00000000 00000000 00000000 00000000 00000000

Displaying enumeration of 4 bridge devices

DeviceID P# S# B# IOB IOL MemBase MemLimit PreBase PreLimit Ctrl
8086:2560 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000
8086:2561 00 01 01 F000 0000 FD000000 FE1FFFFF F5E00000 F7FFFFFF 0008
8086:244E 00 05 05 1000 1FFF FC500000 FC7FFFFF FFF00000 00000000 0006
8086:24C0 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000

GA_enumerateDevices: Found 1 PCI/AGP display devices

Valid ISV license found - using licensed options
Loading driver for device 0: 1 0 0 10DE:002D 0000:0000
---------------------------------------------------------

Monitor record loaded from disk:
Manufacturer... COMPAQ
Model.......... COMPAQ S710
Max Resolution. 1280x1024
Max HScan...... 70 KHz
Max VScan...... 160 Hz
Features....... DPMS

Attempting to enable write combining, base = 0xF6000000, length = 0x02000000
... Success!
Attempting to disable caching for MMIO, base = 0xFD000000, length =
0x01000000 ... Success!

Graphics device configuration:
Manufacturer......... NVIDIA
Chipset.............. RIVA-TNT2 M64
Memory............... 32768 Kb
DAC.................. NVIDIA Internal 24 bit DAC
Clock................ NVIDIA Internal Clock
Memory Clock......... 15 Mhz
Default Memory Clock. 0 Mhz
Maximum Memory Clock. 0 Mhz
Driver Revision...... Build 8
Driver Build......... Feb 15 2000
Certified Version..... Not Certified

Driver for device 0 loaded successfully!
---------------------------------------------------------

Patrick Pfister

Re: X11 with Scitech and Compaq Evo

Post by Patrick Pfister » Wed Mar 26, 2003 12:09 pm

thanks - nice idea... did not change anything though.
it looks as if scitech (???) searches hardwaresettings or "snoops" around...
similar effects were when "allow tcp" is activated in Xconfig.$Node file
(/etc/config/X11)
my "set" gives the following output, maybe that gives you any further hints:

BROWSER=/usr/stdt//c/MAP/

DATE=Wed Mar 26 11:33:26 2003

DIRNAME=/usr/stdt

GMS_HOME=/usr/gms

HOME=/usr/stdt/GMS

HZ=1000

IFS=

INCLUDE=/usr/include:/usr/PP/include:/usr/stdt/c/itc:/usr/stdt/c/tools:/usr/
stdt/c/globals

KSH_VERSION=QNX 4.20

LIB=/usr/lib

LINEDEF=CR

LISTEN_PFAD=/usr/stdt/db/

LOGNAME=stdtx

MAIL=/usr/spool/mail/stdtx

MAILCHECK=600

MODMAP=Switzerland

NODE=35

OPTIND=1

PATH=/bin:/etc:/usr/bin:/etc:/usr/ucb:/usr/local/bin:/qnx4/scitech/bin/:/bin
:/usr/bin:/usr/stdt/bin:/usr/bin/X11:/usr/gms/bin:/usr/stdt/bin:/usr/PPgms.V
2/bin:.:/usr/zim42

PROJ=/usr/stdt/

PROJECT=beck

PS1=#

PS2=>

PWD=/usr/stdt/GMS

SECONDS=50

SHELL=/bin/sh

SHLEVEL=1

SYSNAME=qnx4

TERM=qnx

TMPDIR=/tmp

TTY=//35/dev/con1

TZ=utc0dst-1,M3.5.0/2,M10.5.0/2

VBIOS_METHOD=2

WVIDEO=-nofpu

WVIDEO_PATH=/etc/wvideo

XSERVER=/usr/X11/Metro23/bin/Xscitech

ZIM=/usr/zim42

_=set


"David Donohoe" <ddonohoe@qnx.com> schrieb im Newsbeitrag
news:b5pr1m$kcg$1@nntp.qnx.com...
Patrick Pfister <patrick.pfister@pup.ch> wrote:
got new PCs (Compaq Evo310 Microtower) for our application, running X11
with
Scitechdriver on QNX 4.25...
TNT2 graphiccard (the only one I could find that still runs!!!)...
onboard
VGA deactivated!
Photon start as quick as usual - X11 or better Scitechdriver (gatest and
startx) take up to 1 min to give an image !!!
Shutting down X11 is a little quicker (but still 15 seconds) :-(!
does anybody have answers to such things???
thanks for any hints!!!!

Try setting VBIOS_METHOD environment variable to 2, e.g.

export VBIOS_METHOD=2

attached the graphics.log:


391 Mhz Unknown Intel processor with MMX(R), SSE(R)

Displaying enumeration of PCI bus (7 devices, 1 display devices)
Display device 0 is PCI device 5

Bus Slot Fnc DeviceID SubSystem Rev Class IRQ Base10h Base14h Cmd
0 0 0 8086:2560 0000:0000 01 06:00 00 F8000008 00000000 0106
0 1 0 8086:2561 0000:0000 01 06:04 00 00000000 00000000 0107
0 30 0 8086:244E 0000:0000 81 06:04 00 00000000 00000000 0107
0 31 0 8086:24C0 0000:0000 01 06:01 00 00000000 00000000 010F
0 31 1 8086:24CB 0E11:00C5 01 01:01 0A 00002091 000020A1 0005
1 0 0 10DE:002D 0000:0000 15 03:00 0A FD000000 F6000008 0027
- 0
5 4 0 10EC:8139 10BD:0320 10 02:00 05 00001001 FC500000 0007

DeviceID Stat Ifc Cch Lat Hdr BIST Int Base18h Base1Ch Base20h
Base24h
8086:2560 2090 00 00 00 00 00 00 00000000 00000000 00000000
00000000
8086:2561 00A0 00 00 40 01 00 00 20010100 22A000F0 FE10FD00
F7F0F5E0
8086:244E 8080 00 00 00 01 00 00 40050500 22801010 FC70FC50
0000FFF0
8086:24C0 0280 00 00 00 80 00 00 00000000 00000000 00000000
00000000
8086:24CB 0280 8A 00 00 00 00 01 00002099 000020A5 00002081
00000000
10DE:002D 02B0 00 00 40 00 00 01 00000000 00000000 00000000
00000000
- 0
10EC:8139 0280 00 00 42 00 00 01 00000000 00000000 00000000
00000000

DeviceID BAR10Len BAR14Len BAR18Len BAR1CLen BAR20Len BAR24Len ROMLen
8086:2560 04000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:2561 00000000 00000000 07000100 FD5F1000 000F0100 000F0100 00000000
8086:244E 00000000 00000000 07000100 FD7F1000 000F0100 000F0100 00000000
8086:24C0 00000000 00000000 00000000 00000000 00000000 00000000 00000000
8086:24CB 00000000 00000000 00000000 00000000 00000000 00000000 00000000
10DE:002D 01000000 02000000 00000000 00000000 00000000 00000000 00000000
-
0
10EC:8139 00000000 00000100 00000000 00000000 00000000 00000000 00000000

Displaying enumeration of 4 bridge devices

DeviceID P# S# B# IOB IOL MemBase MemLimit PreBase PreLimit Ctrl
8086:2560 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000
8086:2561 00 01 01 F000 0000 FD000000 FE1FFFFF F5E00000 F7FFFFFF 0008
8086:244E 00 05 05 1000 1FFF FC500000 FC7FFFFF FFF00000 00000000 0006
8086:24C0 00 00 00 0000 0000 00000000 00000000 00000000 00000000 0000

GA_enumerateDevices: Found 1 PCI/AGP display devices

Valid ISV license found - using licensed options
Loading driver for device 0: 1 0 0 10DE:002D 0000:0000
---------------------------------------------------------

Monitor record loaded from disk:
Manufacturer... COMPAQ
Model.......... COMPAQ S710
Max Resolution. 1280x1024
Max HScan...... 70 KHz
Max VScan...... 160 Hz
Features....... DPMS

Attempting to enable write combining, base = 0xF6000000, length =
0x02000000
... Success!
Attempting to disable caching for MMIO, base = 0xFD000000, length =
0x01000000 ... Success!

Graphics device configuration:
Manufacturer......... NVIDIA
Chipset.............. RIVA-TNT2 M64
Memory............... 32768 Kb
DAC.................. NVIDIA Internal 24 bit DAC
Clock................ NVIDIA Internal Clock
Memory Clock......... 15 Mhz
Default Memory Clock. 0 Mhz
Maximum Memory Clock. 0 Mhz
Driver Revision...... Build 8
Driver Build......... Feb 15 2000
Certified Version..... Not Certified

Driver for device 0 loaded successfully!
---------------------------------------------------------

Post Reply

Return to “qdn.public.ddk.graphics”