View topic - Porting OpenSSL new version to QNX 6.5.0

Page 1 of 1

Porting OpenSSL new version to QNX 6.5.0

PostPosted: Tue May 05, 2020 12:37 pm
by samchacko777
I am working on web server application on qnx 6.5.0 which have a dependency on the OpenSSL. The OpenSSL lib present in the qnx 6.5.0. is old version and my application requires OpenSSL 1.1.1( New veriosn) . I am currently trying to port the openssl 1.1.1 to qnx 6.5.0. In the new openSSL source ,they don't have config options for QNX 6.5.0, I am currently struggling to proceed, any help will be much appreciated.

Re: Porting OpenSSL new version to QNX 6.5.0

PostPosted: Tue May 05, 2020 2:35 pm
by Tim
Hi Sam,

Here's a link where someone was working on the same thing. They don't mention if they completed it but it should get you started and mentions things you'll need to resolve.
http://openssl.6102.n7.nabble.com/QNX-6 ... 74950.html

That said, OpenSSL says they removed the QNX build options when moving to 1.1.1 because they couldn't find anyone to verify version/licenses under QNX (search for QNX).
https://www.openssl.org/news/cl111.txt

Note that QNX 7 provides OpenSSL 1.1.1
http://www.qnx.com/developers/docs/7.0. ... rypto.html

So depending on your relationship with QNX (ie is your support contract current) you may want to contact your QNX Rep and ask then how they compiled it for QNX 7. Or ask over at Foundy27 (where QNX Dev's hang out).

Tim

Re: Porting OpenSSL new version to QNX 6.5.0

PostPosted: Wed May 06, 2020 1:55 pm
by samchacko777
Hi Tim ,

Thank you for the quick response. I will surely check the inputs provided from your side.

Sam