View topic - Fix warnings while starting screen

Fix warnings while starting screen

QNX Application portings.

Fix warnings while starting screen

Postby sheran.vaz » Fri Sep 16, 2016 7:03 pm

When starting screen, i see belwo warnings in sloginfo

Sep 16 19:01:45 5 8 300 screen: starting up...
Sep 16 19:01:45 5 8 300 screen: connected to powman...
Sep 16 19:01:45 3 8 915 [ihold:265]"warning"
Sep 16 19:01:45 5 8 300 screen: loading EGL display 1...
Sep 16 19:01:45 5 8 300 screen: loading blit module gles2blt...
Sep 16 19:01:46 3 8 100 egl: the format in egl config [8] dosen't match with native buffer [0]


Any ideas how to fix these?

Regards
Sheran
sheran.vaz
Senior Member
 
Posts: 101
Joined: Mon May 11, 2009 9:17 am

Re: Fix warnings while starting screen

Postby sanurmen » Fri Sep 14, 2018 6:05 am

At least in my case this message appeared when wrong display was configured in graphics.conf.

  • In /usr/lib/graphics/intel-drm/graphics.conf following items were referencing display 2
    • winmgr/globals/default-display
    • winmgr/"begin display"
    • winmgr/framebuffer
  • Running "screen" + "drm-probe-displays" showed that only display 1 was connected
After changing all those references to display 1 the problem disappeared and UI performance was improved.
sanurmen
New Member
 
Posts: 3
Joined: Thu Sep 13, 2018 9:25 am

Re: Fix warnings while starting screen

Postby sanurmen » Mon Sep 17, 2018 6:48 am

Correcting my post above. Actually that change broke framebuffer by pointing it to nonexisting pipeline. Initially I had both EGL and framebuffer configured to same pipeline and that seemed to cause the performance issue. That "fixed" both the performance and the log warnings.

Now that I fixed the framebuffer by configuring it to use same display but separate pipeline, the performance is ok, but the warning reappeared. So it seems that warning is seen when framebuffer device is enabled in graphics.conf.
sanurmen
New Member
 
Posts: 3
Joined: Thu Sep 13, 2018 9:25 am

Re: Fix warnings while starting screen

Postby sanurmen » Thu Oct 11, 2018 12:35 pm

This was fixed by changing "usage = inteldrm" to "usage = gles2" in the framebuffer section of graphics.conf
sanurmen
New Member
 
Posts: 3
Joined: Thu Sep 13, 2018 9:25 am


Return to Porting

Who is online

Users browsing this forum: No registered users and 3 guests

cron