View topic - Qt On Qnx 6.5

Qt On Qnx 6.5

Discussion about the general applications that run on QNX6

Qt On Qnx 6.5

Postby mylavarapumanikanta23 » Tue Dec 19, 2017 9:54 am

I Want to design application on qt ,so that it can run on any os(i.e linux,windows,xenomai and qnx) with minimal compilation.

For that how can i download a qt package which supports QNX 6.5.Here my host pc is Windows7(32-bit).

What are the tools required to install qt on qnx 6.5.

Please tell me the latest version of qt which can be run on linux 3.10.32,xenomai 2.6, windows 7 and 10, and qnx 6.5.

Note:I am thinking to download Qt 5.9(Long Term Support)package
mylavarapumanikanta23
Active Member
 
Posts: 17
Joined: Sat Sep 23, 2017 5:40 am

Re: Qt On Qnx 6.5

Postby maschoen » Fri Dec 22, 2017 4:25 am

The QNX relationship with Qt/Digia has been a bit rocky. QNX decided to drop their own GUI Photon and just let people take up the slack with Qt. For a while they tried to get palsy with Digia. At first this looked good. A version of Qt was ported to QNX, maybe 4.2 or 4.3. The original port was done using a Linux development system by someone at QNX. The Qt configure/make didn't seem to work. I stepped in and made a few changes and was able to build Qt for QNX, at least for x86. It run on top of the graphics layer QNX build for QNX 6.4 and 6.5, which also supported Photon and OpenGL ES. Then Digia discovered a rather disheartening problem that has to do with the strange license situation with Qt.

You can get Qt as open source, as well as a licensed version. At the 4.2 and 4.3 level, I could discern no difference between the two versions. On top of that, the only reason to pay for the licensed version was to get support from Digia. But they didn't seem to have anyone on board who knew anything about QNX. Things seemed to have soured a bit.

Along came Qt 5.0. As far as I know, QNX did some work so that it would work on the 6.6 graphics layer, screen.

At some point I found some 4.x version of Qt would not compile because, get this, it required Linux specific .h files. So much for QNX support. I put together a package a few years ago with instructions on how to do a build of a specific version, maybe 4.3 on a QNX host. If you want to try this on Windows/Momentics, you are on your own. I also had some tools so that you could develop using Photon. That's right, even though QNX insisted it would be impossible, I could run a Qt program under Photon. The best part was that the code was native. You could run the same executable without Photon, but not in a window. Let me know if you want the package and I'll get you the details.
maschoen
QNX Master
 
Posts: 2667
Joined: Wed Jun 25, 2003 5:18 pm

Re: Qt On Qnx 6.5

Postby Thunderblade » Wed Jan 10, 2018 9:14 am

I wouldn't go for Qt 4.x, it's quite old. 5.x runs on QNX with 'screen', their GPU abstraction layer introduced with 6.6. It meanwhile has also been released for 6.5, but only with a limited set of GPUs being supported.

Qt 5 is running well on QNX, but I think with 6.5 there's a limitation coming from the toolchain, the compiler doesn't support C++11, which I think is used in Qt from 5.4 onwards.

The new license model for Qt, as far as I understand it is that if you are building an embedded device, you have to pay a runtime license.
Thunderblade
Senior Member
 
Posts: 489
Joined: Thu Apr 07, 2005 11:52 am


Return to QNX6 - Applications

Who is online

Users browsing this forum: No registered users and 3 guests

cron