View topic - slogger log file corruption

Page 1 of 1

slogger log file corruption

PostPosted: Sat Jun 07, 2008 10:02 am
by bugmenot
Hello,

I'm using slogger ( slogger -l /tmp/log) to log messages received by can driver. The problem is a garbage that periodically appeares in log. No other application writes to the log (I've checked this. When drivers doesn't work there is nothing in log ).
What's wrong?

E.g.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x4a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x5a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3a0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x6a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x3b0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3b0 and length 8 byte(s) received.
Feb 17 17:48:16 2 683621 515 980579442 1679831072 979465313 671100960 1052782 10002 319928614 1852534357 544110447
........
this garbage appears periodically ( period: 4-10 seconds )
........
1936942445 543516513 1752459639 543451424 1647605808 185100960 771100960 1056254 10002 319928614 1852534357
Mar 23 19:48:33 7 222573 1847 with id 0x3a0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x5b0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x3a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x4a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x6b0 and length 8 byte(s) received.
Feb 21 00:03:34 6 10001 2 /dev/can0 << id: 0x5a0 len: 0x8 rtr: 0 data: 0
Feb 21 00:03:34 6 10002 0 Unknown message with id 0x3a0 and length 8 byte(s) received.

Oasis Palm Cancun
Sexo Por Telefono

RE: slogger log file corruption

PostPosted: Sat Jun 07, 2008 12:05 pm
by bugmenot
Next test.
This program writes test messages.

//main
while(1)
{
delay(100);
slogf( 1,1,"%s","test");
}

slogger is running ("slogger -l /tmp/log").

I inspect log file by the command:
"sloginfo /tmp/log".
Garbage appeares in 3 minutes after the start.

There is no problems when i use /dev/shmem/log as log file.

I have QNX 6.3.2 running on x86 proceesor board ( CF is used as hrad disk )

Re: slogger log file corruption

PostPosted: Wed Jan 09, 2019 7:11 pm
by madokapeng
any solutions to solve this?

I am experiencing the same issue.

Re: slogger log file corruption

PostPosted: Thu Jan 10, 2019 7:47 am
by nico04
Do you really need a log file ?
Running "slogger" is enough (reading with "sloginfo").