View topic - Installing QNX 6.4.1 on Intel i3-6100

Installing QNX 6.4.1 on Intel i3-6100

Discussion about the QNX6 OS.

Installing QNX 6.4.1 on Intel i3-6100

Postby kkboy1 » Thu Aug 15, 2019 7:45 am

I tried to install QNX 6.4.1 on CF card but during booting it hangs at qnxbasedma.ifs....
It only hang on this i3-6100 machine, works on the other older model.
I am not sure what happens that cause it to hang?
Any suggestions?

I format the CF card using the following and copy the files from the qnx6 virtual machine (vmware)

fdisk /dev/hd1 delete -a
fdisk /dev/hd1 add -s 1 -t 179 -b -p 100
fdisk -B /boot/sys/ipl-diskpc1 /dev/hd1 loader

mount -e /dev/hd1t179
mkqnxfs /dev/hd1t179
mount -t -qnx6 -o sync=ignore /dev/hd1t179 /mnt

cp -vcr /.boot /mnt
cp -vcr /bin /mnt
cp -vcr /etc /mnt
cp -vcr /lib /mnt
cp -vcr /root /mnt
cp -vcr /sbin /mnt
cp -vcr /usr /mnt
cp -vcr /var /mnt


Add: I have try to boot from the QNX6 CD.
It also hangs at Booting QNX SDP ..........................................
kkboy1
New Member
 
Posts: 2
Joined: Thu Aug 15, 2019 2:05 am

Re: Installing QNX 6.4.1 on Intel i3-6100

Postby Tim » Thu Aug 15, 2019 1:36 pm

So what else did you do besides what you listed above?

In other words what's in your .boot image. That's what's not booting so without that info we can't help in the least.

What kind of machine is the 13-6100 (manufacturer + hardware specs).

Tim
Tim
Senior Member
 
Posts: 1446
Joined: Wed Mar 10, 2004 12:28 am

Re: Installing QNX 6.4.1 on Intel i3-6100

Postby kkboy1 » Fri Aug 16, 2019 9:01 am

i3-6100 is the CPU used.

using the below build to create .boot :

[virtual=x86,bios +compress] boot = {
startup-bios -s64K

# PATH is the *safe* path for executables (confstr(_CS_PATH...))
# LD_LIBRARY_PATH is the *safe* path for libraries (confstr(_CS_LIBPATH))
# i.e. This is the path searched for libs in setuid/setgid executables.
PATH=/proc/boot:/sbin:/bin:/usr/sbin:/usr/bin:/opt/bin LD_LIBRARY_PATH=/proc/boot:/lib:/usr/lib:/lib/dll:/opt/lib procnto-instr
}

[+script] startup-script = {
# To save memory make everyone use the libc in the boot image!
# For speed (less symbolic lookups) we point to libc.so.3 instead of libc.so
display_msg Welcome to QNX Neutrino trunk on an PC compatible BIOS system
procmgr_symlink ../../proc/boot/libc.so.3 /usr/lib/ldqnx.so.2

# Start up some consoles
devc-con -n4 &
reopen /dev/con1

slogger &

# Start the pci server
seedres
pci-bios &
waitfor /dev/pci

# Some common servers
pipe &
mqueue &
devc-ser8250 -e &
devc-pty &

# Start a debug server for debugging programs
#waitfor /dev/ser1
#[+session] pdebug /dev/ser1 &

# These env variables inherited by all the programs which follow
SYSNAME=nto
TERM=qansi

# Start some extra shells on other consoles
reopen /dev/con2
[+session] sh &
reopen /dev/con3
[+session] sh &

# Start a high priority shell just in case....
reopen /dev/con4
[pri=25 +session] sh &

# Start the main shell
reopen /dev/con1
[+session] sh
# [+session] login -p
}
kkboy1
New Member
 
Posts: 2
Joined: Thu Aug 15, 2019 2:05 am

Re: Installing QNX 6.4.1 on Intel i3-6100

Postby Tim » Fri Aug 16, 2019 2:08 pm

Since it never displays your "Welcome to QNX Neutrino trunk on an PC compatible BIOS system" message we can infer that it never even starts to boot your image. This fits with the fact you can't boot from the QNX 6 install CD either.

That makes me thinks it's BIOS related. Look here to see what's recommended for 6.5 (essentially the same as 6.4) in terms of BIOS settings
http://www.qnx.com/developers/docs/6.5. ... hosts.html

I suspect something in the BIOS is preventing it from booting. Maybe see if the SATA has an IDE compatibility mode, turn off USB boot options etc.

Tim
Tim
Senior Member
 
Posts: 1446
Joined: Wed Mar 10, 2004 12:28 am


Return to QNX6 - OS

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron