View topic - Proc 4.25O

Proc 4.25O

For the old QNX2 and QNX4 RTOS

Proc 4.25O

Postby juanplacco » Wed Apr 18, 2007 8:55 pm

Hi,

I had a problem upgrading Proc32 to version 4.25O. Is the version unestable? I was working with a previous version (4.25L in some machines and 425J in others) and i had no problem.

What I could see was a dead Proc and the stack shown in screen.
The versions of Fsys is 4.24Y and Fsys.eide 4.25G.

I have the 4.25Q version, but I don't know if using it will solve the problem.

Did somebody had the same problem?

Thanks in advance
juanplacco
Senior Member
 
Posts: 318
Joined: Wed May 17, 2006 2:30 pm

RE: Proc 4.25O

Postby mario » Wed Apr 18, 2007 9:22 pm

Maybe if you explain what the problem is that would help us help you.

Why are you upgrading to 4.25O in the first place.

I have no idea if 4.25Q will solve your problem since I don't know what the problem is ;-)

The only time I had problem when upgrading kernel was because of stuff in the code that should not have been done in the first place.

Check the release notes ( assuming there are some )
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am

RE: Proc 4.25O

Postby juanplacco » Wed Apr 18, 2007 9:38 pm

There is no good reason for upgrading. I just want to test that revision of Proc (I supposed newer==better, and I was obvious wrong). The only thing I can tell you is what I did. I had a couple of processes runnig in the upgraded machine (a scada), and for one reason or another (needed of re-synchronize processes between them) I had to killed one. After my slay -f my_scada_process the stack was shown in the console telling me that something was very vey bad...
That machine was working fine with the same scada running on it...

Thanks again
Bye
juanplacco
Senior Member
 
Posts: 318
Joined: Wed May 17, 2006 2:30 pm


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 1 guest