View topic - using mountimg

Page 1 of 1

using mountimg

PostPosted: Fri Nov 30, 2018 8:57 pm
by mhborovay
I have created a floppy diskette image. When I run the mountimg utility, I found that not all the files appeared. Also, there were times that when I wanted to display the contents of a directory, the following error occurred:
ls: readdir of 'archive' failed (Invalid argument).

Other times I would not able to see the files in the directory and the error would be "corrupted file systems".

I see that mountimg is an unsupported utility. I also saw the utility will exit if the file is fragmented. I created the image file by typing the following:

cp /dev/fd0 /tmp/archive.img.

Then a typed as a superuser the following:
mountimg -c -m /tmp/archive_1 -v archive.img
I don't know if there was fragmentation on the floppy image file because there were no errors displayed.

I also use WinImage on my Windows box to create floppy images of the same QNX floppy diskette. I had the same problems mentioned earlier.

Does anyone know if there are issues with "mountimg" utility and if there are any work around.

Thanks,

Mark

Re: using mountimg

PostPosted: Sat Dec 01, 2018 9:17 pm
by Tim
Hi Mark,

I don't remember the last time I used mountimg. Maybe 20 years ago or more. But googling around I found these 2 links

http://community.qnx.com/sf/discussion/ ... _post47681
(see the last post)

https://openqnx.com/phpbbforum/viewtopic.php?t=6642

Hopefully one of these will help you.

Tim

Re: using mountimg

PostPosted: Wed Dec 26, 2018 7:31 pm
by space
Try using "dd if=/dev/fd0 of=/tmp/archive.img" to create the image. I do not believe "cp" will work for what you are attempting.

Re: using mountimg

PostPosted: Wed Dec 26, 2018 10:26 pm
by maschoen
space wrote:Try using "dd if=/dev/fd0 of=/tmp/archive.img" to create the image. I do not believe "cp" will work for what you are attempting.


It always has for me.