View topic - NIC (PCMCIA) sometimes not functional in QNX4

NIC (PCMCIA) sometimes not functional in QNX4

For the old QNX2 and QNX4 RTOS

NIC (PCMCIA) sometimes not functional in QNX4

Postby WhiteRabbits » Tue May 08, 2018 1:33 pm

Sometimes (more often not) I can "ping" other hosts from a freshly booted QNX4 machine.
I always can ping the QNX machine from itself.

When I can not, I get a "spawned" message before, during boot. Here's the full text :
iotype=601 l->type=601
Locking ioport=320-32f ioport2=0-ffffffff irq=5 in socket 1
spawned //1/bin/Net.ether82595

When I retrieve the PCMCIA NIC :
Net.ether82595: Terminating from signal 0xf
When inserting again :
spawned //1/bin/Net.ether82595

The PC is a Sony Vaio laptop and the NIC is Olicom 82595. Mind it works sometimes .....

Does anyone have any ideas where to look next ?
Helge
WhiteRabbits
Senior Member
 
Posts: 198
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany

Re: NIC (PCMCIA) sometimes not functional in QNX4

Postby maschoen » Wed May 09, 2018 12:37 pm

If you remove and insert the card, does that fix the problem?

What is your goal, to have the system always boot properly?

It maybe the case that you are dealing with glitchy hardware. That could be the PCMCIA chips, or it could be your network card. And it could be a flaky bug in the QNX PCMCIA server. If it is the latter, you are SOL. You would have to pay QNX an arm and a leg to fix the problem if they were at all willing, not very likely.
maschoen
QNX Master
 
Posts: 2677
Joined: Wed Jun 25, 2003 5:18 pm

Re: NIC (PCMCIA) sometimes not functional in QNX4

Postby WhiteRabbits » Wed May 09, 2018 9:03 pm

Thank you !

It does not get any better when I retrieve -> insert again the PCMCIA card. By the rate of unsuccessful restarts (which I feel is increasing over the yeras, but I'm not sure) I guess I'll follow your advice and go for new hardware.

Actually, the boot finishes well on this laptop, I just cannot remotely control it by phrelay, which is a little inconvenient, though not very.

Sincerely, Helge
WhiteRabbits
Senior Member
 
Posts: 198
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 2 guests