View topic - Fsys.atapi problem

Fsys.atapi problem

For the old QNX2 and QNX4 RTOS

Fsys.atapi problem

Postby lhait » Wed Jul 30, 2008 9:14 am

I'm use Advantech PCA-6187 Pentium-4 CPU-Card with Intel 82801 EB Controller and I need to support HD and CD drives with Fsys.atapi driver.

CD drive connected to the first IDE Port and looks like Master at the first IDE Port.

Serial ATA Hard Disk connected to the first SATA Port and looks like Master at the second IDE Port.

In BIOS On-Chip Serial ATA setting is [AUTO].

Only

Fsys.atapi atapi ioport=0x1f0,irq=14,master=atapi

support CD drive properly.

Fsys.atapi atapi ioport=0x170,irq=15 - hangs computer.

I can work with HD only with Fsys.eide driver.
Last edited by lhait on Thu Jul 31, 2008 5:38 am, edited 1 time in total.
lhait
Active Member
 
Posts: 42
Joined: Fri Aug 15, 2003 4:54 pm

RE: Fsys.atapi problem

Postby ysinitsky » Wed Jul 30, 2008 7:25 pm

Hello Lhait,
It is worth while trying an experimental version posted at

http://community.qnx.com/sf/discussion/ ... t.topc3390

Regards,
Yuriy
ysinitsky
Senior Member
 
Posts: 164
Joined: Wed Dec 14, 2005 8:46 pm

RE: Fsys.atapi problem

Postby ianc » Thu Jul 31, 2008 1:23 am

What we do is run Fsys.atapi in the .boot image
and start Fsys.eide in the sysinit

sata disk drive on first controller cd on second controller

in boot image Fsys.atapi atapi ioport=0x01f0,irq=14

in sysinit Fsys.eide eide -a 170 -i 15
ianc
Active Member
 
Posts: 83
Joined: Wed Jan 22, 2003 6:04 am
Location: Bendigo, Australia

RE: Fsys.atapi problem

Postby lhait » Thu Jul 31, 2008 5:48 am

Thanks to ianc. I was correcting my mistake with irq number.

You can try to support CD with Fsys.atapi too

Fsys.atapi atapi ioport=0x170,irq=15,master=atapi

But I remain with problem of support of the hard disk with Fsys.atapi
lhait
Active Member
 
Posts: 42
Joined: Fri Aug 15, 2003 4:54 pm


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 4 guests