View topic - Installing libaudiofile and other apps from pkgsrc

Page 1 of 1

Installing libaudiofile and other apps from pkgsrc

PostPosted: Fri Feb 27, 2015 2:33 pm
by ippp0
Hi all!

My system is 6.4.0 and I'm trying to install various applications from the 640_HEAD repository at http://community.qnx.com/svn/repos/pkgsrc/HEAD_640 (for example VLC, xine-lib, -ui, Gtetrinet).

These programs and their dependencies mostly end up with Error Code 1.

This for example is the end of the installation of libaudiofile, which is necessary for many apps:
Code: Select all
........creating writeraw
source='writeavr.c' object='writeavr.o' libtool=no  depfile='.deps/writeavr.Po'
tmpdepfile='.deps/writeavr.TPo'  depmode=gcc3 /bin/sh ../depcomp  gcc -DHAVE_CON
FIG_H -I. -I. -I.. -I../libaudiofile     -O2 -c `test -f writeavr.c || echo './'
`writeavr.c
writeavr.c: In function 'main':
writeavr.c:66: error: 'int16_t' undeclared (first use in this function)
writeavr.c:66: error: (Each undeclared identifier is reported only once
writeavr.c:66: error: for each function it appears in.)
writeavr.c:66: error: expected ';' before 'samples'
writeavr.c:79: error: 'samples' undeclared (first use in this function)
writeavr.c:106: error: expected ';' before 'temporary'
writeavr.c:108: error: 'temporary' undeclared (first use in this function)
*** Error code 1

Stop.
bmake: stopped in /usr/share/pkgsrc/HEAD_640/pkgsrc/audio/libaudiofile/work/audi
ofile-0.2.6/test
*** Error code 1

Stop.
bmake: stopped in /usr/share/pkgsrc/HEAD_640/pkgsrc/audio/libaudiofile/work/audi
ofile-0.2.6
*** Error code 1

Stop.
bmake: stopped in /usr/share/pkgsrc/HEAD_640/pkgsrc/audio/libaudiofile/work/audi
ofile-0.2.6
*** Error code 1

Stop.
bmake: stopped in /usr/share/pkgsrc/HEAD_640/pkgsrc/audio/libaudiofile
*** Error code 1

Stop.
bmake: stopped in /usr/share/pkgsrc/HEAD_640/pkgsrc/audio/libaudiofile


I tried many other packages and every one gave me this error, mostly at the End of the compiling process.

So my question is about a common method to figure out why these problems occur or solve them as a non-programmer.

Any suggestions or hints?

thanks!

Re: Installing libaudiofile and other apps from pkgsrc

PostPosted: Fri Feb 27, 2015 6:33 pm
by maschoen
I don't know anything about libaudiofile. I have worked with pkgsrc quite a bit. There are a few thousand applications in the tree. Not all of them compile properly with QNX. pkgsrc still provides the advantage of automatically figuring out dependancies and pre-compiling them. This is much easier then searching the web for source and by trial and error descending the dependency tree.

It is possible to fix the problems. pkgsrc has a method of pushing any fixes back to the source. I don't know how active the project is at QNX. Still you need to be a programmer with the skill to research why you are getting the error(s) and the knowledge to figure out how to fix the problem. There's no way around that.