View topic - No Audio Coming on Speakers

Page 1 of 1

No Audio Coming on Speakers

PostPosted: Mon Jun 10, 2013 6:21 am
by ksanthi
Hello,

Iam playing a wave file using qnx "wave" utility.But no sound is coming out the speakers connected

# ls -l /dev/snd/
total 0
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 controlC0
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 controlC1
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 controlC2
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 mixerC0D0
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 mixerC1D0
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 mixerC2D0
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC0D0c
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC0D0p
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC0D1p
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC1D0c
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC1D0p
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC1D1p
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC2D0c
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC2D0p
-rw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmC2D1p
lrw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmPreferredc -> pcmC0D0c
lrw-rw-rw- 1 root 0 0 Jan 01 00:01 pcmPreferredp -> pcmC0D1p

#
# wave /media/drive/Buddy.wav
SampleRate = 44100, Channels = 2, SampleBits = 16
Format Signed 16-bit Little Endian
Frag Size 3760
Total Frags 64
Rate 44100
Voices 2
Mixer Pcm Group [Wave playback channel]

Is anything iam missing please help me


Thanks
Santhi.

Re: No Audio Coming on Speakers

PostPosted: Mon Jun 10, 2013 8:27 am
by maschoen
you might try

# wave -a0 ....
# wave -a1 ....
etc.

in case the speakers are not connected to the channel you think.

Re: No Audio Coming on Speakers

PostPosted: Tue Jun 25, 2013 8:00 am
by Thunderblade
Which hardware is this on? Perhaps the corresponding driver does not exactly match your hardware. Are there any messages in sloginfo?