View topic - Lib fftw installation

Page 1 of 1

Lib fftw installation

PostPosted: Fri Jan 20, 2012 9:27 pm
by wallace
I really need some help here.

I`m trying to deploy fftw library on qnx 6.4.1 box. It`s not that easy however (I`m rather new to qnx).
I have found fftw for qnx (ftp://ftp.netbsd.org/pub/NetBSD/package ... EADME.html) it`s in *tgz. When unpacked, there is a bunch of scripts, *h file, and library files (*so, *a). Trying to run +INSTALL script, but it returns "shift: nothing to shift"

I`ve also tried to compile the source. ./configure script fails (returns config.status: error: cannot find input file: `doc/FAQ/Makefile.in`).

Am I doing it wrong?

Re: Lib fftw installation

PostPosted: Fri Jan 20, 2012 10:23 pm
by wallace
Ok, I have solved it. The problem was in fact, that qnx changed folder names to small letters.

I still need some help, however. I`ve installed fftw on qnx box, but for programming purposes I`m using momentics on windows box. Well, now my question is: fftw shoul be installed on (qnx box, as it is) or on windows box? In first case how to show momentics where are *h, and lib files?

Re: Lib fftw installation

PostPosted: Mon Jan 23, 2012 10:55 pm
by Tim
Wallace,

The executable belongs on the QNX box.

Since you are using Momentics in Windows, the .h, .c, .cpp, lib files etc all belong on Windows (assuming you are going to compile it in Momentics). If it's already compiled (ie came with an executable) and ready to run and you don't need to compile then it doesn't matter where the .h, .c, .cpp etc files are.

Tim

Re: Lib fftw installation

PostPosted: Tue Jan 24, 2017 11:45 am
by toyoxx
Dear Wallace

I know it's been 4 years since this thread was last replied. I wanted to ask you if you could be more specific on how you solved the shift: nothing to shift in the +INSTALL script for FFTW?

Hoping you remember

toyoxx!