View topic - USB Launcher giving Lua error.

USB Launcher giving Lua error.

QNX7 release

USB Launcher giving Lua error.

Postby jarinp » Tue May 22, 2018 6:43 am

We are using SDP 7.0 BSP for NXP i.MX6x SABRE for Automotive Infotainment board. We are trying to bring up USB host and connecting USB Mass storage devices.

We are using QNX7 SDP default rules.lua file and rules.mnt file for configuring the USB Launcher for getting the PPS updates.

Following is the error log we received.
-->> Dec 31 19:09:58.642 usblauncher_otg.16398 slog 100 created pps (/pps/qnx/usb/device/usb--->> 1.2?nopersist,critical)
-->> Dec 31 19:09:58.642 usblauncher_otg.16398 slog 100 bus::USB
status::detected
busno::0x01
devno::0x02
vendor_id::0x0781
product_id::0x5590
configurations::1
configuration::1
serial_number::4
device_release::r1.00
USB_version::v2.10
device_class::0x00
max_packet_size0::64
manufacturer::S
product::U
upstream_device_address::0
upstream_host_controller::1
upstream_port::1
upstream_port_speed::High
topology::(0,1)
drivers_matched::1
drivers_running::0

-->> Dec 31 19:09:58.643 usblauncher_otg.16398 slog 100 USB-1.2:0: vid=0781, did=5590: Detected
-->> Dec 31 19:09:58.643 usblauncher_otg.16398 slog 100 USB-1.2:0: vid=0781, did=5590: Launch devb-umass blk cache=1m,vnode=384,auto=none,delwri=2:2,rmvto=none,noatime disk name=umass cdrom name=umasscd umass priority=21,vid=0x781,did=0x5590,busno=0x1,devno=0x2,iface=0,ign_remove
-->> Dec 31 19:09:58.644 usblauncher_otg.16398 [color=#FF0000]slog 100 Lua error: 2: [string "builtin_functions"]:355: devb-umass: No such file or directory[/color]
-->> stack traceback:
[C]: in function 'assert'
[string "builtin_functions"]:355: in function <[string "builtin_functions"]:343>

What could be the possible reason for this error?

Thanks for your support, in advance.
jarinp
New Member
 
Posts: 1
Joined: Mon May 21, 2018 12:32 pm

Re: USB Launcher giving Lua error.

Postby nico04 » Tue May 22, 2018 6:50 am

Most obvious reasons are :
- devb-umass not present in file system
- devb-umass location not in PATH
- devb-umass not executable
nico04
Senior Member
 
Posts: 115
Joined: Wed Sep 29, 2010 9:59 am
Location: France


Return to QNX7

Who is online

Users browsing this forum: No registered users and 1 guest