View topic - Configuring an Application

Configuring an Application

anything that doesn't fit to other groups.

Configuring an Application

Postby Netwarrior » Tue Jan 13, 2004 11:08 am

HI tehre guys.

I've been evaluating 6.2.1 for a while, and I notice something strange, strange for me, maybe it's normal for qnx.

When I compile an ( x ) application, and I run the configure script, it takes about half an hour to run it!!!!, the machine is a pentium 233 mmx with 128 of ram, well then, I installed solaris 8 in the same machine, and it take
3 minutes to run that godforsken script, the same for *UNIX, linux freebsd.

I do not understand how an RTOS can take such a long time to do that simple thing. maybe someone experienced the same behabior before..

I was wandering that if I plan to develop something in that machine, I better give away :)), or do I need a dual pentium 4 do do something with QNX?

Any ideas?

Thanx a lot.
Netwarrior
Active Member
 
Posts: 38
Joined: Wed Dec 24, 2003 2:11 pm

Postby rick » Tue Jan 13, 2004 2:50 pm

A couple. :-)

Watch the output and see if it pauses for a long time doing something - you can tail -f config.log in another window if there is not enough info the main screen. That may give you a cluse as to what it is blocked on.

Another possibility is the disk driver is slow, although I have trouble with that on an older machine. It may be interesting to see if the CPU meter is pegged during this whole process, or what it's activity looks like.

Because of the way the package file system works, it will be slower than a pure disk based file system, but 10 times longer seems a little overboard - the CPU usage should give a clue to this.
rick
QNX Master
 
Posts: 500
Joined: Wed Nov 13, 2002 3:59 am

Configuring an Appz

Postby Netwarrior » Tue Jan 13, 2004 5:19 pm

As long as I can see, the output is normal, it take much more time than the normal, that's all, but indeed, it eats the cpu, that's why I found it weird, cause the same appz under linux or solaris, works fine.

I'll give it a try on another Machine..

Thanx 4 your time.


rick wrote:A couple. :-)

Watch the output and see if it pauses for a long time doing something - you can tail -f config.log in another window if there is not enough info the main screen. That may give you a cluse as to what it is blocked on.

Another possibility is the disk driver is slow, although I have trouble with that on an older machine. It may be interesting to see if the CPU meter is pegged during this whole process, or what it's activity looks like.

Because of the way the package file system works, it will be slower than a pure disk based file system, but 10 times longer seems a little overboard - the CPU usage should give a clue to this.
Netwarrior
Active Member
 
Posts: 38
Joined: Wed Dec 24, 2003 2:11 pm

Postby noc » Tue Jan 13, 2004 7:06 pm

noc
Senior Member
 
Posts: 1634
Joined: Sat Jul 06, 2002 4:34 am

Postby cdm » Wed Jan 14, 2004 7:01 am

Try doing...

CC=qcc CXX=QCC ./configure ...

It will speed it up a fair bit. Or wait for 6.3.0, no more fs-pkg. :)
cdm
QNX Master
 
Posts: 789
Joined: Fri Jul 05, 2002 9:38 am


Return to General Programming

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron