Trouble creating a package - "No new packages to install"

bridged with qdn.public.porting
Post Reply
Mathieu Dubé-Dallaire

Trouble creating a package - "No new packages to install"

Post by Mathieu Dubé-Dallaire » Fri Oct 31, 2003 7:13 pm

Hi,

I just created my first package for QNX and everything seems to have gone
right. However, when I want to test it out and install it, I'm running into
some trouble. It seems the installer doesn't see the included packages.
# cl-installer -i rt-lab_x86-6.2.1-x86-opalrt.qpr

QNX Software Installer 1.00

Extracted QRM identifier
Opening "/pkgs/repository" repository and looking for packages...
Opening "/pkgs/base" repository and looking for packages...

Extracted QRM identifier
Opening "rt-lab_x86-6.2.1-x86-opalrt.qpr" repository and looking for
packages...

There are no new packages to install.
Session closed
Thank for any advice,

Mathieu

Jerry Chappell

Re: Trouble creating a package - "No new packages to install

Post by Jerry Chappell » Mon Nov 03, 2003 2:49 pm

You might see some more detail on what's going wrong if you use the
graphical installer (qnxinstall), just to open and look at your generated
packages.

My guess is that the version might be incorrect--you can't use a newly
generated package with an old installer. The way around it is to use the -L
option to packager, when you create your packages.

Jerry Chappell


"Mathieu Dubé-Dallaire" <mathieu.dube@opal-rt.com> wrote in message
news:oprxw80wbwe9us2t@localhost...
Hi,

I just created my first package for QNX and everything seems to have gone
right. However, when I want to test it out and install it, I'm running
into
some trouble. It seems the installer doesn't see the included packages.

# cl-installer -i rt-lab_x86-6.2.1-x86-opalrt.qpr

QNX Software Installer 1.00

Extracted QRM identifier
Opening "/pkgs/repository" repository and looking for packages...
Opening "/pkgs/base" repository and looking for packages...

Extracted QRM identifier
Opening "rt-lab_x86-6.2.1-x86-opalrt.qpr" repository and looking for
packages...

There are no new packages to install.
Session closed

Thank for any advice,

Mathieu

Post Reply

Return to “qdn.public.porting”