Using PCMCIA IDE Flash with qnx4?

bridged with qdn.public.qnx4
Post Reply
M. Tavasti

Using PCMCIA IDE Flash with qnx4?

Post by M. Tavasti » Sat Dec 27, 2003 3:34 pm

I would need some help for using PCMCIA IDE Flash with qnx4. Device
itself is SanDisk Compact flash with PC Card adapter. I found this:

http://www.qnx.com/support/sd_bok/solution.qnx?750

Unfortunately pin does not show any IO-addr & IRQ values. Pin output
for that device is:
Sock Win Type Flags PID Base Size IRQ ......
2 0 Memory C---M---------W None - -

(Hand-written, so may be bit inaccurate, but information is same.

I tried to boot to linux & look values there, but those values did not
work, no eide device found there. (Tried IO 0x100 & 0x10e)

System is 4.25E, should it be something else?

--
M. Tavasti / tavasti@iki.fi / +358-40-5078254

Hugh Brown

Re: Using PCMCIA IDE Flash with qnx4?

Post by Hugh Brown » Mon Jan 05, 2004 1:16 pm

Have you added this device to your /etc/config/pcmcia.cards file?

"M. Tavasti" <tavastixx@iki.fi.invalid> wrote in message
news:m2ad5e1dhg.fsf@akvavitix.vuovasti.com...
I would need some help for using PCMCIA IDE Flash with qnx4. Device
itself is SanDisk Compact flash with PC Card adapter. I found this:

http://www.qnx.com/support/sd_bok/solution.qnx?750

Unfortunately pin does not show any IO-addr & IRQ values. Pin output
for that device is:
Sock Win Type Flags PID Base Size IRQ ......
2 0 Memory C---M---------W None - -

(Hand-written, so may be bit inaccurate, but information is same.

I tried to boot to linux & look values there, but those values did not
work, no eide device found there. (Tried IO 0x100 & 0x10e)

System is 4.25E, should it be something else?

--
M. Tavasti / tavasti@iki.fi / +358-40-5078254

M. Tavasti

Re: Using PCMCIA IDE Flash with qnx4?

Post by M. Tavasti » Thu Jan 08, 2004 7:05 pm

"Hugh Brown" <hsbrown@qnx.com> writes:
itself is SanDisk Compact flash with PC Card adapter. I found this:
Have you added this device to your /etc/config/pcmcia.cards file?
No, what to add there?

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

Hugh Brown

Re: Using PCMCIA IDE Flash with qnx4?

Post by Hugh Brown » Fri Jan 09, 2004 12:59 pm

With the card inserted in the socket do a 'pin con >>
/etc/config/pcmcia.cards', then slay Pcmcia.generic and re-start it as
'Pcmcia.generic -i0'. You should now see your device correctly with 'pin'.

"M. Tavasti" <tavastixx@iki.fi.invalid> wrote in message
news:m2hdz6z2eq.fsf@akvavitix.vuovasti.com...
"Hugh Brown" <hsbrown@qnx.com> writes:

itself is SanDisk Compact flash with PC Card adapter. I found this:
Have you added this device to your /etc/config/pcmcia.cards file?

No, what to add there?

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

M. Tavasti

Re: Using PCMCIA IDE Flash with qnx4?

Post by M. Tavasti » Wed Jan 14, 2004 4:41 am

"Hugh Brown" <hsbrown@qnx.com> writes:
With the card inserted in the socket do a 'pin con
/etc/config/pcmcia.cards', then slay Pcmcia.generic and re-start it as
'Pcmcia.generic -i0'. You should now see your device correctly with 'pin'.
Didn't help.

pin con only adds these lines:

; socket 2
[device]
register = 0, 0x40, 0x40 ; level mode interrupts

And apparently this is not enough...

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

Hugh Brown

Re: Using PCMCIA IDE Flash with qnx4?

Post by Hugh Brown » Wed Jan 14, 2004 1:01 pm

Please can you post the output from 'pin cis'?

"M. Tavasti" <tavastixx@iki.fi.invalid> wrote in message
news:m2smijxhtp.fsf@akvavitix.vuovasti.com...
"Hugh Brown" <hsbrown@qnx.com> writes:

With the card inserted in the socket do a 'pin con
/etc/config/pcmcia.cards', then slay Pcmcia.generic and re-start it as
'Pcmcia.generic -i0'. You should now see your device correctly with
'pin'.

Didn't help.

pin con only adds these lines:

; socket 2
[device]
register = 0, 0x40, 0x40 ; level mode interrupts

And apparently this is not enough...

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

M. Tavasti

Re: Using PCMCIA IDE Flash with qnx4?

Post by M. Tavasti » Sat Jan 17, 2004 1:37 pm

"Hugh Brown" <hsbrown@qnx.com> writes:
Please can you post the output from 'pin cis'?
Socket : 2
pin con only adds these lines:

; socket 2
[device]
register = 0, 0x40, 0x40 ; level mode interrupts
--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

Hugh Brown

Re: Using PCMCIA IDE Flash with qnx4?

Post by Hugh Brown » Mon Jan 19, 2004 1:08 pm

There has got to be something wrong here! There should be more output than
this! Have you tried changing the memory address in your
/etc/config/pcmcia.cfg file? The default is 0xd4000, but some machines have
BIOS is this area. Please also post the output from 'show_pci -vv'.

"M. Tavasti" <tavastixx@iki.fi.invalid> wrote in message
news:m2d69iy9v4.fsf@akvavitix.vuovasti.com...
"Hugh Brown" <hsbrown@qnx.com> writes:

Please can you post the output from 'pin cis'?

Socket : 2

pin con only adds these lines:

; socket 2
[device]
register = 0, 0x40, 0x40 ; level mode interrupts

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

Hugh Brown

Re: Using PCMCIA IDE Flash with qnx4?

Post by Hugh Brown » Mon Jan 19, 2004 1:09 pm

I should add that you must slay and re-start Pcmcia.generic every time you
change the address in the pcmcia.cfg file.

"Hugh Brown" <hsbrown@qnx.com> wrote in message
news:bugkcq$4ur$1@nntp.qnx.com...
There has got to be something wrong here! There should be more output than
this! Have you tried changing the memory address in your
/etc/config/pcmcia.cfg file? The default is 0xd4000, but some machines
have
BIOS is this area. Please also post the output from 'show_pci -vv'.

"M. Tavasti" <tavastixx@iki.fi.invalid> wrote in message
news:m2d69iy9v4.fsf@akvavitix.vuovasti.com...
"Hugh Brown" <hsbrown@qnx.com> writes:

Please can you post the output from 'pin cis'?

Socket : 2

pin con only adds these lines:

; socket 2
[device]
register = 0, 0x40, 0x40 ; level mode interrupts

--
M. Tavasti / tavastixx@iki.fi / +358-40-5078254
Poista sähköpostiosoitteesta molemmat x-kirjaimet
Remove x-letters from my e-mail address

Post Reply

Return to “qdn.public.qnx4”