Problems with EFS image

bridged with qnx.bsp
Post Reply
Nito

Problems with EFS image

Post by Nito » Tue Jan 30, 2007 5:59 pm

Hi all!

I'm now trying to work with QNX over my Total5200v2.

I has created a QNX System Builder Project with this functionallity:

serial ports,
pci server,
network driver,
remote debug,
flash driver (devf-mgt5200 -s0xfc000000, 64M),
usb,
graphics,
spi,
and i2c.

Using the 'Combine image(s)' button, I has added to it an IPL (the
ipl-mgt5200) with a pad of 128KB. In the 'Final processing' section,
I has fixed a 0x20000 offset and binary format.

I has built the project, downloaded and programmed the flash memory
with it using the instructions:

dn ipl.bin
fp fe000000 fe020001 20000

dn -s mgt5200.srec
fp fe040000 fee9bfff 20000


After that, I has created an QNX System Builder EFS Project with the
QNX Momentics IDE and I only has added one file (/usr/lib/libAp.so.3)
to this project. I has filled the following project properties as
follows:

Block size: 256K
Filesystem: ffs3
Filter:
Image mount point: /
Maximum Image Size: 32M
Minimum Image Size:256K
Spare Blocks: 6

I has built it and I has downloaded it and programmed it into the
flash memory using the commands:

dn mgt5200.gag-flash1.efs
fp fc000000 fc2fffff 20000

Now, I'm trying to get access to my flash filesystem using the
flashtcl and devf-mgt5200 binaries, but I don't know how to do it. My
attempts are been always failed.

Could anybody gives me some help??

Thanks in advance.

Benito Urquiola

Post Reply

Return to “qnx.bsp”