Code coverage plugin not working

bridged with qnx.development_tools
Post Reply
mallard

Code coverage plugin not working

Post by mallard » Tue Dec 11, 2007 9:54 pm

Hey,

I am trying to use the Code Coverage plugin in the IDE and I can't get
any good results out of it. Help anyone?

The code is meant for an embedded system but I'm testing it on a x86
platform; it does not interact with Photon. The unit tests work fine
but I can't get the plugin to give me good numbers. It has erratic
behavior, sometimes crashing outright, sometimes reporting bad
numbers (coverage stops halfway through a source code file),
sometimes not connecting. Is there something in my setup that
prevents it from working correctly, or is the plugin just buggy? The
release notes mention some issues with it.

I am using QNX 6.3.2, IDE 4.0.1, gcc 3.3.5, Windows host (dual-core
P4), x86 target (running in VMWare) and qconn. Otherwise, everything
runs fine. Switching to gcc 2.95.3 doesn't help.

--
mallard

Alex Chapiro

Re: Code coverage plugin not working

Post by Alex Chapiro » Thu Dec 13, 2007 3:02 pm

Are you using last qconn on your target?

mallard wrote:
Hey,

I am trying to use the Code Coverage plugin in the IDE and I can't get
any good results out of it. Help anyone?

The code is meant for an embedded system but I'm testing it on a x86
platform; it does not interact with Photon. The unit tests work fine
but I can't get the plugin to give me good numbers. It has erratic
behavior, sometimes crashing outright, sometimes reporting bad
numbers (coverage stops halfway through a source code file),
sometimes not connecting. Is there something in my setup that
prevents it from working correctly, or is the plugin just buggy? The
release notes mention some issues with it.

I am using QNX 6.3.2, IDE 4.0.1, gcc 3.3.5, Windows host (dual-core
P4), x86 target (running in VMWare) and qconn. Otherwise, everything
runs fine. Switching to gcc 2.95.3 doesn't help.

--
mallard

mallard

RE: Re: Code coverage plugin not working

Post by mallard » Thu Dec 13, 2007 7:53 pm

Yes, I recently upgraded everything, host and target. On the target
properties in the "Run..." window, qconn is reported as
using the latest version. I had similar, but even worse, problems
with the coverage plugin with the previous version the QNX suite
(6.3.0 sp2 I think).

I am about to give up on this and use gcov directly. Too bad, that
plugin would have been useful.

--
mallard

Alex Chapiro

Re: Code coverage plugin not working

Post by Alex Chapiro » Fri Dec 14, 2007 2:34 pm

Is it possible to have an example from you?

mallard wrote:
Yes, I recently upgraded everything, host and target. On the target
properties in the "Run..." window, qconn is reported as
using the latest version. I had similar, but even worse, problems
with the coverage plugin with the previous version the QNX suite
(6.3.0 sp2 I think).

I am about to give up on this and use gcov directly. Too bad, that
plugin would have been useful.

--
mallard

mallard

RE: Re: Code coverage plugin not working

Post by mallard » Fri Dec 14, 2007 9:54 pm

I'm not sure what you're asking for, for an example. The code base
that I use is about 30 kLOC long. I tried the plugin with small,
trivial projects and it ran fine. Lately, when I run my test suite
(which takes about 30 min to run), the code coverage monitor stops
after a couple of minutes ("<stopped> MyProgram - Coverage
[gcc Code Coverage]" in debug Window), and the coverage data is
no longer updated.

Post Reply

Return to “qnx.development_tools”