Momentics 6.2.1a - Can't debug "Hello World"

bridged with qdn.public.devtools
Post Reply
roger

Momentics 6.2.1a - Can't debug "Hello World"

Post by roger » Wed Aug 27, 2003 10:54 pm

I am new to QNX and have just started my development.

I am able to generate and build a sample application. No errors
or warnings are generated during compilation.

When I launch the debugger, I get a Launch configuration error, namely:
Exception occurred processing launch configuration. See log for more
information.
Reason:
Exception occurred while launching.

More Info about my development platform:
Platform: Momentics under W2K
Project Type: QNX C Application
Momentics: V6.2.1a
Target: Self-Hosted X86

Log file:
!ENTRY org.eclipse.debug.ui 4 120 Aug 27, 2003 15:53:05.59
!MESSAGE Error logged from Debug UI:
!STACK 1
org.eclipse.core.runtime.CoreException[150]:
org.eclipse.cdt.debug.core.cdi.CDIException: Error initializing: Exec
error:Launching failed
at
org.eclipse.cdt.debug.mi.core.GDBDebugger.createLaunchSession(GDBDebugger.ja
va:47)
at
org.eclipse.cdt.launch.internal.LocalCLaunchConfigurationDelegate.launch(Loc
alCLaunchConfigurationDelegate.java:84)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfigurati
on.java:136)
at
org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationDialog
$10.run(LaunchConfigurationDialog.java:2299)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext
..java:98)
!ENTRY org.eclipse.cdt.launch 4 150 Aug 27, 2003 15:53:05.59
!MESSAGE Failed Launching CDI Debugger : Error initializing: Exec
error:Launching failed
!STACK 0
org.eclipse.cdt.debug.core.cdi.CDIException: Error initializing: Exec
error:Launching failed
at
org.eclipse.cdt.debug.mi.core.GDBDebugger.createLaunchSession(GDBDebugger.ja
va:47)
at
org.eclipse.cdt.launch.internal.LocalCLaunchConfigurationDelegate.launch(Loc
alCLaunchConfigurationDelegate.java:84)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfigurati
on.java:136)
at
org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationDialog
$10.run(LaunchConfigurationDialog.java:2299)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext
..java:98)


Please Help!

Thanks

Roger

Alain Magloire

Re: Momentics 6.2.1a - Can't debug "Hello World"

Post by Alain Magloire » Fri Aug 29, 2003 2:04 pm

roger <rogeryung@mtmeng.com> wrote:
: I am new to QNX and have just started my development.

: I am able to generate and build a sample application. No errors
: or warnings are generated during compilation.

: When I launch the debugger, I get a Launch configuration error, namely:
: Exception occurred processing launch configuration. See log for more
: information.
: Reason:
: Exception occurred while launching.

So this is not a QNX project, nor a QNX launcher.
In that case make sure you have "gdb" in your path or change in the launch
configuration "Debug ..." the location of gdb. It has to be gdb 5.2.1 and above.

tyy

Re: Momentics 6.2.1a - Can't debug "Hello World"

Post by tyy » Wed Oct 22, 2003 4:33 am

perhaps you need to run "qconn &" first

"roger" <rogeryung@mtmeng.com> дÈëÓʼþ news:bijbui$2qg$1@inn.qnx.com...
I am new to QNX and have just started my development.

I am able to generate and build a sample application. No errors
or warnings are generated during compilation.

When I launch the debugger, I get a Launch configuration error, namely:
Exception occurred processing launch configuration. See log for more
information.
Reason:
Exception occurred while launching.

More Info about my development platform:
Platform: Momentics under W2K
Project Type: QNX C Application
Momentics: V6.2.1a
Target: Self-Hosted X86

Log file:
!ENTRY org.eclipse.debug.ui 4 120 Aug 27, 2003 15:53:05.59
!MESSAGE Error logged from Debug UI:
!STACK 1
org.eclipse.core.runtime.CoreException[150]:
org.eclipse.cdt.debug.core.cdi.CDIException: Error initializing: Exec
error:Launching failed
at

org.eclipse.cdt.debug.mi.core.GDBDebugger.createLaunchSession(GDBDebugger.ja
va:47)
at

org.eclipse.cdt.launch.internal.LocalCLaunchConfigurationDelegate.launch(Loc
alCLaunchConfigurationDelegate.java:84)
at

org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfigurati
on.java:136)
at

org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationDialog
$10.run(LaunchConfigurationDialog.java:2299)
at

org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext
.java:98)
!ENTRY org.eclipse.cdt.launch 4 150 Aug 27, 2003 15:53:05.59
!MESSAGE Failed Launching CDI Debugger : Error initializing: Exec
error:Launching failed
!STACK 0
org.eclipse.cdt.debug.core.cdi.CDIException: Error initializing: Exec
error:Launching failed
at

org.eclipse.cdt.debug.mi.core.GDBDebugger.createLaunchSession(GDBDebugger.ja
va:47)
at

org.eclipse.cdt.launch.internal.LocalCLaunchConfigurationDelegate.launch(Loc
alCLaunchConfigurationDelegate.java:84)
at

org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfigurati
on.java:136)
at

org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationDialog
$10.run(LaunchConfigurationDialog.java:2299)
at

org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext
.java:98)


Please Help!

Thanks

Roger


Post Reply

Return to “qdn.public.devtools”