Problem debugging multithreaded app on self hosted QNX6.2.1

bridged with qdn.public.devtools
Post Reply
jdl

Problem debugging multithreaded app on self hosted QNX6.2.1

Post by jdl » Tue Jul 15, 2003 9:44 am

Hi,

After upgrading to QNX6.2.1 Supplemental, I'm not able anymore to step
through the code. I place a breakpoint in one of the threads, all the
threads are suspended. The correct thread is marked stepping. But the
variables view is empty. And if I try to step, the debugger is stepping
thread [1].
Attached you can find the eclipse error log.

Jo


begin 666 dump.txt
M(45.5%)9(&]R9RYE8VQI<'-E+F1E8G5G+F-O<F4@-" Q,C @2G5L(#$U+" R
M,# S(#$P.C T.C4T+C,W,PT*(4U%4U-!1T4@17)R;W(@;&]G9V5D(&9R;VT@
M1&5B=6<@0V]R93H@#0HA4U1!0TL@, T*:F%V82YI;RY)3T5X8V5P=&EO;CH@
M8VQO<V4@97)R;W(-"@T*4W1A8VL@=')A8V4Z#0H@("!J879A+VQA;F<O5&AR
M;W=A8FQE+CQI;FET/B@I5@T*(" @:F%V82]L86YG+U1H<F]W86)L92X\:6YI
M=#XH3&IA=F$O;&%N9R]3=')I;F<[*58-"B @(&]R9R]E8VQI<'-E+V-D="]U
M=&EL<R]P='DO4%193W5T<'5T4W1R96%M+F-L;W-E*"E6#0H@("!O<F<O96-L
M:7!S92]D96)U9R]I;G1E<FYA;"]C;W)E+TEN<'5T4W1R96%M36]N:71O<BYW
M<FET92@I5@T*(" @;W)G+V5C;&EP<V4O9&5B=6<O:6YT97)N86PO8V]R92])
M;G!U=%-T<F5A;4UO;FET;W(D,2YR=6XH*58-"B @(&IA=F$O;&%N9R]4:')E
-860N<G5N*"E6#0H-"@``
`
end

Mikhail Khodjaiants

Re: Problem debugging multithreaded app on self hosted QNX6.

Post by Mikhail Khodjaiants » Tue Jul 15, 2003 6:52 pm

Could you provide a test case?

"jdl" <fkroket@mail.be> wrote in message news:bf0etf$8fd$1@nntp.qnx.com...
Hi,

After upgrading to QNX6.2.1 Supplemental, I'm not able anymore to step
through the code. I place a breakpoint in one of the threads, all the
threads are suspended. The correct thread is marked stepping. But the
variables view is empty. And if I try to step, the debugger is stepping
thread [1].
Attached you can find the eclipse error log.

Jo


jdl

Re: Problem debugging multithreaded app on self hosted QNX6.

Post by jdl » Thu Jul 17, 2003 3:30 pm

I sended a reduced project to your mail account.

Jo


"Mikhail Khodjaiants" <mikhailk@qnx.com> wrote in message
news:bf1ir2$k54$1@nntp.qnx.com...
Could you provide a test case?

"jdl" <fkroket@mail.be> wrote in message news:bf0etf$8fd$1@nntp.qnx.com...
Hi,

After upgrading to QNX6.2.1 Supplemental, I'm not able anymore to step
through the code. I place a breakpoint in one of the threads, all the
threads are suspended. The correct thread is marked stepping. But the
variables view is empty. And if I try to step, the debugger is stepping
thread [1].
Attached you can find the eclipse error log.

Jo




Post Reply

Return to “qdn.public.devtools”