Debugging in IDE

bridged with qdn.public.devtools
Post Reply
Francois Joubert

Debugging in IDE

Post by Francois Joubert » Wed May 07, 2003 11:01 am

I have successfully compiled and build a Photon app. When I want to debug
the app using qconn, I get a launch configuration error "Exception occurred
while launching".

The log indicates a stack overflow, and one entry that seems to repeat
itself (some 8000 times) are:

org/eclipse/cdt/debug/internal/core/sourcelookup/CSourceLocator.addReference
dSourceLocations(Ljava/util/List;Lorg/eclipse/core/resources/IProject;)V


Another test app works fine! What is the problem?

Francois

Anders Lundeby

Re: Debugging in IDE

Post by Anders Lundeby » Thu May 15, 2003 3:44 pm

Hi!

Got the same problem, but our app contains references to dynamic
libraries only, at it is not a photon app. It runs when downlaoded
to the file system and started separately. Tried both to launch
from the debugger, and attach to a running process, no difference.
If I ignore the error message, it seems like it is possible to step
in the program, we got line number information in the debug view,
variables also showing correct. The only (basic) thing missing is to be
able to step in the source code.

??

best,

Anders Lundeby


Francois Joubert <francoisj@andis.co.za> wrote in message
news:b9ansp$gr7$1@inn.qnx.com...
I have successfully compiled and build a Photon app. When I want to debug
the app using qconn, I get a launch configuration error "Exception
occurred
while launching".

The log indicates a stack overflow, and one entry that seems to repeat
itself (some 8000 times) are:


org/eclipse/cdt/debug/internal/core/sourcelookup/CSourceLocator.addReference
dSourceLocations(Ljava/util/List;Lorg/eclipse/core/resources/IProject;)V


Another test app works fine! What is the problem?

Francois

Francois Joubert

Re: Debugging in IDE

Post by Francois Joubert » Mon May 19, 2003 1:38 pm

The only way I resolved it was to dump all the source code into a single
project. Not ideal but at least I can continue.

Francois


"Anders Lundeby" <anders@scanmatic.no> wrote in message
news:ba0c9b$lfe$1@nntp.qnx.com...
Hi!

Got the same problem, but our app contains references to dynamic
libraries only, at it is not a photon app. It runs when downlaoded
to the file system and started separately. Tried both to launch
from the debugger, and attach to a running process, no difference.
If I ignore the error message, it seems like it is possible to step
in the program, we got line number information in the debug view,
variables also showing correct. The only (basic) thing missing is to be
able to step in the source code.

??

best,

Anders Lundeby


Francois Joubert <francoisj@andis.co.za> wrote in message
news:b9ansp$gr7$1@inn.qnx.com...
I have successfully compiled and build a Photon app. When I want to
debug
the app using qconn, I get a launch configuration error "Exception
occurred
while launching".

The log indicates a stack overflow, and one entry that seems to repeat
itself (some 8000 times) are:



org/eclipse/cdt/debug/internal/core/sourcelookup/CSourceLocator.addReference
dSourceLocations(Ljava/util/List;Lorg/eclipse/core/resources/IProject;)V


Another test app works fine! What is the problem?

Francois



Mikhail Khodjaiants

Re: Debugging in IDE

Post by Mikhail Khodjaiants » Tue Jul 15, 2003 6:57 pm

This happens if you have cross reference projects.

"Francois Joubert" <francoisj@andis.co.za> wrote in message
news:b9ansp$gr7$1@inn.qnx.com...
I have successfully compiled and build a Photon app. When I want to debug
the app using qconn, I get a launch configuration error "Exception
occurred
while launching".

The log indicates a stack overflow, and one entry that seems to repeat
itself (some 8000 times) are:


org/eclipse/cdt/debug/internal/core/sourcelookup/CSourceLocator.addReference
dSourceLocations(Ljava/util/List;Lorg/eclipse/core/resources/IProject;)V


Another test app works fine! What is the problem?

Francois

Post Reply

Return to “qdn.public.devtools”