Hang starting up Momentics IDE under QNX 6.2

bridged with qdn.public.devtools
Post Reply
Dave G.

Hang starting up Momentics IDE under QNX 6.2

Post by Dave G. » Tue Feb 11, 2003 1:32 pm

I have a problem where I can no longer run the IDE under QNX 6.2. When I
start it up, I get the splash screen which never goes away and a process
/usr/eclipse/ive/bin/j9 which is consuming all my CPU time. I can't do
anything but kill the two processes (j9 and /usr/eclipse/show_splash). Are
there any lock files or any other thing I could clear to get past this
problem? This problem persists even after re-installing the IDE and
patches.

TIA,
Dave G.

Chris McKillop

Re: Hang starting up Momentics IDE under QNX 6.2

Post by Chris McKillop » Tue Feb 11, 2003 4:46 pm

As a trial, move your workspace directory in $HOME out of the way and see
if it starts up properly. ie:

mv $HOME/workspace $HOME/old-workspace

chris


Dave G. <~~~dkg@ormec.com> wrote:
I have a problem where I can no longer run the IDE under QNX 6.2. When I
start it up, I get the splash screen which never goes away and a process
/usr/eclipse/ive/bin/j9 which is consuming all my CPU time. I can't do
anything but kill the two processes (j9 and /usr/eclipse/show_splash). Are
there any lock files or any other thing I could clear to get past this
problem? This problem persists even after re-installing the IDE and
patches.

TIA,
Dave G.

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Dave G.

Re: Hang starting up Momentics IDE under QNX 6.2

Post by Dave G. » Tue Feb 11, 2003 11:53 pm

Hi Chris,

OK, That took care of the hang on startup. So I guess something in my
workspace is corrupt? How do I locate the problem or do I need to recreate
my workspace?

Thanx,
Dave G.


"Chris McKillop" <cdm@qnx.com> wrote in message
news:b2b9e2$936$1@nntp.qnx.com...
As a trial, move your workspace directory in $HOME out of the way and see
if it starts up properly. ie:

mv $HOME/workspace $HOME/old-workspace

chris


Dave G. <~~~dkg@ormec.com> wrote:
I have a problem where I can no longer run the IDE under QNX 6.2. When
I
start it up, I get the splash screen which never goes away and a process
/usr/eclipse/ive/bin/j9 which is consuming all my CPU time. I can't do
anything but kill the two processes (j9 and /usr/eclipse/show_splash).
Are
there any lock files or any other thing I could clear to get past this
problem? This problem persists even after re-installing the IDE and
patches.

TIA,
Dave G.



--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Chris McKillop

Re: Hang starting up Momentics IDE under QNX 6.2

Post by Chris McKillop » Wed Feb 12, 2003 2:10 am

Dave G. <~~~dkg@ormec.com> wrote:
Hi Chris,

OK, That took care of the hang on startup. So I guess something in my
workspace is corrupt? How do I locate the problem or do I need to recreate
my workspace?
Move the workspace directory back and then do "rm $HOME/workspace/.metadata/.log" and re-start the IDE. If (when) it bails on you post the new .log file here.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Dave G.

Re: Hang starting up Momentics IDE under QNX 6.2

Post by Dave G. » Wed Feb 12, 2003 6:41 pm

There does not appear to be a .log file created by the time the hang occurs.
Is there an option to generate a log file earlier in the startup process?

BTW, I've kept an image of my old workspace so I can continue chasing down
this problem if you have any further instructions.

Dave G.

"Chris McKillop" <cdm@qnx.com> wrote in message
news:b2cafd$svk$1@nntp.qnx.com...
Dave G. <~~~dkg@ormec.com> wrote:
Hi Chris,

OK, That took care of the hang on startup. So I guess something in my
workspace is corrupt? How do I locate the problem or do I need to
recreate
my workspace?


Move the workspace directory back and then do "rm
$HOME/workspace/.metadata/.log" and re-start the IDE. If (when) it bails on
you post the new .log file here.
chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Post Reply

Return to “qdn.public.devtools”