Problems with setjmp/longjmp in PIC on PPC?

bridged with qdn.public.qnxrtp.powerpc
Post Reply
Benzy Gabay

Problems with setjmp/longjmp in PIC on PPC?

Post by Benzy Gabay » Thu Feb 14, 2002 8:25 pm

Hi,

It seems to us that setjmp/longjmp is not working when called from code
that's compiled with "-shared" on PowerPC under QNX 6.1A.

Is this a known problem? Any workaround?

--
Cheers
==============
Benzy Gabay

Kris Warkentin

Re: Problems with setjmp/longjmp in PIC on PPC?

Post by Kris Warkentin » Fri Feb 15, 2002 3:17 pm

Boy, you always find the tricky ones. I'm almost wondering if there isn't
something in the nature of PIC code that would cause it to be
impossible/impractical to support longjmp(). Do you know if it works with
other (ie x86) architectures? We'll look into this further and get back to
you.

cheers,

Kris
"Benzy Gabay" <bgabay@maya-st.com> wrote in message
news:a4h62p$ler$1@inn.qnx.com...
Hi,

It seems to us that setjmp/longjmp is not working when called from code
that's compiled with "-shared" on PowerPC under QNX 6.1A.

Is this a known problem? Any workaround?

--
Cheers
==============
Benzy Gabay

Benzy Gabay

Re: Problems with setjmp/longjmp in PIC on PPC?

Post by Benzy Gabay » Sun Feb 17, 2002 8:22 am

Kris,

False alarm.....
its my mistake, after trying few time to verify that the longjmp does not
work, I found it actually working.
You can follow my letters on ddk.netwrok and understand the whole picture.

Sorry.

--
Cheers
==============
Benzy Gabay


"Kris Warkentin" <kewarken@qnx.com> wrote in message
news:a4j8ga$3ts$1@nntp.qnx.com...
Boy, you always find the tricky ones. I'm almost wondering if there isn't
something in the nature of PIC code that would cause it to be
impossible/impractical to support longjmp(). Do you know if it works with
other (ie x86) architectures? We'll look into this further and get back
to
you.

cheers,

Kris
"Benzy Gabay" <bgabay@maya-st.com> wrote in message
news:a4h62p$ler$1@inn.qnx.com...
Hi,

It seems to us that setjmp/longjmp is not working when called from code
that's compiled with "-shared" on PowerPC under QNX 6.1A.

Is this a known problem? Any workaround?

--
Cheers
==============
Benzy Gabay



Kris Warkentin

Re: Problems with setjmp/longjmp in PIC on PPC?

Post by Kris Warkentin » Mon Feb 18, 2002 2:54 pm

Whew....One less piece of nastiness to chase. ;-)

Kris
"Benzy Gabay" <bgabay@maya-st.com> wrote in message
news:a4notb$bl2$1@inn.qnx.com...
Kris,

False alarm.....
its my mistake, after trying few time to verify that the longjmp does not
work, I found it actually working.
You can follow my letters on ddk.netwrok and understand the whole picture.

Sorry.

--
Cheers
==============
Benzy Gabay


"Kris Warkentin" <kewarken@qnx.com> wrote in message
news:a4j8ga$3ts$1@nntp.qnx.com...
Boy, you always find the tricky ones. I'm almost wondering if there
isn't
something in the nature of PIC code that would cause it to be
impossible/impractical to support longjmp(). Do you know if it works
with
other (ie x86) architectures? We'll look into this further and get back
to
you.

cheers,

Kris
"Benzy Gabay" <bgabay@maya-st.com> wrote in message
news:a4h62p$ler$1@inn.qnx.com...
Hi,

It seems to us that setjmp/longjmp is not working when called from
code
that's compiled with "-shared" on PowerPC under QNX 6.1A.

Is this a known problem? Any workaround?

--
Cheers
==============
Benzy Gabay





Post Reply

Return to “qdn.public.qnxrtp.powerpc”