3'rd party CD (Emacs) and QNX 6.1A

bridged with qdn.public.qnxrtp.porting
Post Reply
Jens H Jorgensen

3'rd party CD (Emacs) and QNX 6.1A

Post by Jens H Jorgensen » Fri Jun 07, 2002 2:08 pm

The 3'rd party CD is great - no longer searching all over the internet for
life saving libraries and utilities.

One problem that I ran into though:

The emacs binaries on the 3'rd party CD does not work under QNX 6.1A you get
unresolved on:

- freeaddrinfo()
- getaddrinfo()
- gai_strerror()

which I guess are new for the socket library for 6.2

--
Jens

Xiaodan Tang

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Xiaodan Tang » Fri Jun 07, 2002 2:27 pm

Jens H Jorgensen <jhj@remove-nospam-videk.com> wrote:
The 3'rd party CD is great - no longer searching all over the internet for
life saving libraries and utilities.

One problem that I ran into though:

The emacs binaries on the 3'rd party CD does not work under QNX 6.1A you get
unresolved on:

- freeaddrinfo()
- getaddrinfo()
- gai_strerror()

which I guess are new for the socket library for 6.2
I think everything on 3'rd party CD is compiled under 6.2
The tcpip world of 6.2 is totally new compare to 6.1.
Stack, libsocket, headers...

If a 3'rd party software using tcpip, the binary won't
work on 6.1 (usually).

-xtang

Jens H Jorgensen

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Jens H Jorgensen » Fri Jun 07, 2002 4:00 pm

I was wondering if the 3'rd party CD was meant for 6.2, but didn't find any
reference to the fact that it had to be 6.2. I also figured that it was
therefore Mozilla was seperated out by itself because it will only run under
6.2.

--
Jens
"Xiaodan Tang" <xtang@qnx.com> wrote in message
news:adqfru$aup$1@nntp.qnx.com...
Jens H Jorgensen <jhj@remove-nospam-videk.com> wrote:
The 3'rd party CD is great - no longer searching all over the internet
for
life saving libraries and utilities.

One problem that I ran into though:

The emacs binaries on the 3'rd party CD does not work under QNX 6.1A you
get
unresolved on:

- freeaddrinfo()
- getaddrinfo()
- gai_strerror()

which I guess are new for the socket library for 6.2

I think everything on 3'rd party CD is compiled under 6.2
The tcpip world of 6.2 is totally new compare to 6.1.
Stack, libsocket, headers...

If a 3'rd party software using tcpip, the binary won't
work on 6.1 (usually).

-xtang

Frank Liu

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Frank Liu » Fri Jun 07, 2002 5:17 pm

Xiaodan Tang <xtang@qnx.com> wrote:
which I guess are new for the socket library for 6.2

I think everything on 3'rd party CD is compiled under 6.2
The tcpip world of 6.2 is totally new compare to 6.1.
Stack, libsocket, headers...

If a 3'rd party software using tcpip, the binary won't
work on 6.1 (usually).
I haven't looked at it but I seem to remember cdm said
all the ported sources are on the CD. This means you should
be able to compile it on a 6.1 box if you want a 6.1 binary.

frank

Frank Liu

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Frank Liu » Fri Jun 07, 2002 5:18 pm

Jens H Jorgensen <jhj@remove-nospam-videk.com> wrote:
I was wondering if the 3'rd party CD was meant for 6.2, but didn't find any
reference to the fact that it had to be 6.2. I also figured that it was
therefore Mozilla was seperated out by itself because it will only run under
6.2.
Mozilla's separation is a different reason ...

BTW, I've been able to make Mozilla work in both 6.1 and 6.2 now.
the version that is downloadble at http://www.sourceforge.net/projects/openqnx
should work in either 6.1 or 6.2.

Frank

Jens H Jorgensen

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Jens H Jorgensen » Fri Jun 07, 2002 6:42 pm

I just unzip'ed the source and emacs seems have been left out.

--
Jens

"Frank Liu" <liug@mama.indstate.edu> wrote in message
news:adqpqo$ecc$1@inn.qnx.com...
Xiaodan Tang <xtang@qnx.com> wrote:

which I guess are new for the socket library for 6.2

I think everything on 3'rd party CD is compiled under 6.2
The tcpip world of 6.2 is totally new compare to 6.1.
Stack, libsocket, headers...

If a 3'rd party software using tcpip, the binary won't
work on 6.1 (usually).

I haven't looked at it but I seem to remember cdm said
all the ported sources are on the CD. This means you should
be able to compile it on a 6.1 box if you want a 6.1 binary.

frank

Chris McKillop

Re: 3'rd party CD (Emacs) and QNX 6.1A

Post by Chris McKillop » Sat Jun 08, 2002 6:39 am

Jens H Jorgensen <jhj@remove-nospam-videk.com> wrote:
I just unzip'ed the source and emacs seems have been left out.
Emacs actually has a source package on the CDROM.

You can always just get the 6.1 binary from the guys that provided it for
the public cd. http://www.cogent.ca/.

chris

--
Jens

"Frank Liu" <liug@mama.indstate.edu> wrote in message
news:adqpqo$ecc$1@inn.qnx.com...
Xiaodan Tang <xtang@qnx.com> wrote:

which I guess are new for the socket library for 6.2

I think everything on 3'rd party CD is compiled under 6.2
The tcpip world of 6.2 is totally new compare to 6.1.
Stack, libsocket, headers...

If a 3'rd party software using tcpip, the binary won't
work on 6.1 (usually).

I haven't looked at it but I seem to remember cdm said
all the ported sources are on the CD. This means you should
be able to compile it on a 6.1 box if you want a 6.1 binary.

frank


--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Post Reply

Return to “qdn.public.qnxrtp.porting”