KDE 2.0 porting (kdesupport and kdelibs)

bridged with qdn.public.qnxrtp.porting
Post Reply
Ricardo Kazumi Ashikawa

KDE 2.0 porting (kdesupport and kdelibs)

Post by Ricardo Kazumi Ashikawa » Wed Mar 21, 2001 11:18 am

I'm trying to port the KDE minimum set so that I can run any KDE
application.
However, I'm having problems with kdelibs2.0. I can't compile kdesu_pty.cpp,
even if I #include unistd.h so that #define's are correct. Any known
solution?
BTW, if I port qt, kdesupport and kdelibs, is that enough to run KDE and any
of its applications?


Thanks!

Ricardo K. Ashikawa

Sergey Sobolev

Re: KDE 2.0 porting (kdesupport and kdelibs)

Post by Sergey Sobolev » Tue Apr 23, 2002 4:40 pm

"Ricardo Kazumi Ashikawa" <ashikawa@dixtal.com.br> wrote in message
news:999u15$jh2$1@inn.qnx.com...
I'm trying to port the KDE minimum set so that I can run any KDE
application.
However, I'm having problems with kdelibs2.0. I can't compile
kdesu_pty.cpp,
even if I #include unistd.h so that #define's are correct. Any known
solution?
BTW, if I port qt, kdesupport and kdelibs, is that enough to run KDE and
any
of its applications?

Did you get dcopserver running yet?
I have failed message when trying to run it.
_KDE_IceTransSocketOpen: socket() failed for local
_KDE_IceTransSocketOpenCOTSServer: Unable to open socket for local
.......

Is this caused by AF_UNIX sockets?

Regards,
Sergey Sobolev

Guest

Re: KDE 2.0 porting (kdesupport and kdelibs)

Post by Guest » Tue Apr 23, 2002 4:57 pm

I would suggest starting your KDE port in a 6.2 system
where UDS is supported.

frank

Sergey Sobolev <ssobolev@volgasoft.net> wrote:
Did you get dcopserver running yet?
I have failed message when trying to run it.
_KDE_IceTransSocketOpen: socket() failed for local
_KDE_IceTransSocketOpenCOTSServer: Unable to open socket for local
......

Is this caused by AF_UNIX sockets?

Regards,
Sergey Sobolev

Jens H Jorgensen

Re: KDE 2.0 porting (kdesupport and kdelibs)

Post by Jens H Jorgensen » Tue Apr 23, 2002 5:01 pm

Please look at: http://sourceforge.net/projects/openqnx for a port of Qt

--
Jens
"Sergey Sobolev" <ssobolev@volgasoft.net> wrote in message
news:aa426l$npb$1@inn.qnx.com...
"Ricardo Kazumi Ashikawa" <ashikawa@dixtal.com.br> wrote in message
news:999u15$jh2$1@inn.qnx.com...
I'm trying to port the KDE minimum set so that I can run any KDE
application.
However, I'm having problems with kdelibs2.0. I can't compile
kdesu_pty.cpp,
even if I #include unistd.h so that #define's are correct. Any known
solution?
BTW, if I port qt, kdesupport and kdelibs, is that enough to run KDE and
any
of its applications?

Did you get dcopserver running yet?
I have failed message when trying to run it.
_KDE_IceTransSocketOpen: socket() failed for local
_KDE_IceTransSocketOpenCOTSServer: Unable to open socket for local
......

Is this caused by AF_UNIX sockets?

Regards,
Sergey Sobolev

Sergey Sobolev

Re: KDE 2.0 porting (kdesupport and kdelibs)

Post by Sergey Sobolev » Thu Apr 25, 2002 5:33 am

<fliu@bb.vipstage.com> wrote in message news:aa43os$onm$1@inn.qnx.com...
I would suggest starting your KDE port in a 6.2 system
where UDS is supported.

frank
I almost get it working on my 6.1 box with INET sockets.
Unfortunately, I have no access to QNX 6.2. :(

Sergey

Sergey Sobolev

Re: KDE 2.0 porting (kdesupport and kdelibs)

Post by Sergey Sobolev » Thu Apr 25, 2002 10:05 am

<fliu@bb.vipstage.com> wrote in message news:aa43os$onm$1@inn.qnx.com...
I would suggest starting your KDE port in a 6.2 system
where UDS is supported.

Where can I get it????
I think they does not release it yet :(

Post Reply

Return to “qdn.public.qnxrtp.porting”