linux modules under qnx + mount invalid parameter message

bridged with qdn.public.ddk.network
Post Reply
d43d41u5

linux modules under qnx + mount invalid parameter message

Post by d43d41u5 » Tue Jan 13, 2004 11:37 pm

hi

1. Is there a way to use a linux kernel module under qnx ? For example a
linux network driver (I have the source and the binary too ).

2. I've, compiled that null-driver which is in the ddk-network howto, got an
..so, then tried to mount it to io-net, and after executing 'mount -Tio-net
<driverfile>' I've got the message: cannot mount, possible reason: Invalid
argument. Or similar... What could be the problem ?

thanx
Tom

Chris McKillop

Re: linux modules under qnx + mount invalid parameter messag

Post by Chris McKillop » Wed Jan 14, 2004 2:33 am

d43d41u5 <daedalus@freemail.hu> wrote:
hi

1. Is there a way to use a linux kernel module under qnx ? For example a
linux network driver (I have the source and the binary too ).
Not directly. You can use it as a reference though.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Xiaodan Tang

Re: linux modules under qnx + mount invalid parameter messag

Post by Xiaodan Tang » Wed Jan 14, 2004 4:01 pm

d43d41u5 <daedalus@freemail.hu> wrote in message
news:bu1u48$lof$1@inn.qnx.com...
2. I've, compiled that null-driver which is in the ddk-network howto, got
an
.so, then tried to mount it to io-net, and after executing 'mount -Tio-net
driverfile>' I've got the message: cannot mount, possible reason: Invalid
argument. Or similar... What could be the problem ?
Try the fullpath

mount -Tio-net /full/path/to/the/sofile.so

-xtang

d43d41u5

Re: linux modules under qnx + mount invalid parameter messag

Post by d43d41u5 » Wed Jan 14, 2004 6:37 pm

My first thought was that maybe it can't find the file itself. So i tried
with some wrong path, in that case the error message is something different.

"Xiaodan Tang" <xtang@qnx.com> wrote in message
news:bu3oov$2m8$1@nntp.qnx.com...
d43d41u5 <daedalus@freemail.hu> wrote in message
news:bu1u48$lof$1@inn.qnx.com...

2. I've, compiled that null-driver which is in the ddk-network howto,
got
an
.so, then tried to mount it to io-net, and after executing
'mount -Tio-net
driverfile>' I've got the message: cannot mount, possible reason:
Invalid
argument. Or similar... What could be the problem ?

Try the fullpath

mount -Tio-net /full/path/to/the/sofile.so

-xtang

Post Reply

Return to “qdn.public.ddk.network”