Cursor disappears after call to PgSetVideoMode

bridged with qdn.public.qnxrtp.photon
Post Reply
Pierre AUBERT

Cursor disappears after call to PgSetVideoMode

Post by Pierre AUBERT » Tue Sep 30, 2003 7:19 am

Hi everybody,

I use PgSetVideoMode in my program to change the display mode. It works
well but
after I've called this function, the cursor disappears.

Why ? How can I retrieve my cursor ?


Best regards

PS: I'm using QNX6.2.1B

Dave Rempel

Re: Cursor disappears after call to PgSetVideoMode

Post by Dave Rempel » Tue Sep 30, 2003 2:07 pm

Pierre AUBERT wrote:
Hi everybody,

I use PgSetVideoMode in my program to change the display mode. It works
well but
after I've called this function, the cursor disappears.

Why ? How can I retrieve my cursor ?


Best regards

PS: I'm using QNX6.2.1B
It's a bug. Workaround would be to put up a region that covers the
display, change that regions cursor to something, and then change it
back to what you want, then destroy the region.

Pierre AUBERT

Re: Cursor disappears after call to PgSetVideoMode

Post by Pierre AUBERT » Tue Sep 30, 2003 2:49 pm

Dave Rempel wrote:
Pierre AUBERT wrote:

Hi everybody,

I use PgSetVideoMode in my program to change the display mode. It
works well but
after I've called this function, the cursor disappears.

Why ? How can I retrieve my cursor ?


Best regards

PS: I'm using QNX6.2.1B


It's a bug. Workaround would be to put up a region that covers the
display, change that regions cursor to something, and then change it
back to what you want, then destroy the region.

I will try this, thanks
Regards

Post Reply

Return to “qdn.public.qnxrtp.photon”